Come ripristinare e aggiornare il plugin Java bloccato

Questo articolo non è più mantenuto e il suo contenuto potrebbe essere obsoleto.

Le versioni obsolete di Java sono state recentemente aggiunte all'elenco dei plugin bloccati di Firefox e sono state quindi disattivate. È stata presa questa decisione in quanto le versioni meno aggiornate risultano vulnerabili ad un attacco che potrebbe portare in ultima analisi al controllo del computer all'insaputa del suo utilizzatore e al conseguente accesso ai file in esso contenuti o al furto di informazioni sensibili come le credenziali bancarie. Questo articolo descrive i passi da eseguire per aggiornare Java e farlo funzionare correttamente.

Le versioni obsolete risultano vulnerabili ad un attacco che potrebbe portare in ultima analisi al controllo del computer all'insaputa del suo utilizzatore e al conseguente accesso ai file in esso contenuti o al furto di informazioni sensibili come le credenziali bancarie. Questo articolo descrive i passi da eseguire per aggiornare Java e farlo funzionare correttamente.

Aggiornare Java

In Firefox sono state bloccate unicamente le versioni vulnerabili di Java. È quindi opportuno effettuare l'aggiornamento alla versione più recente del plugin. Purtroppo, la semplice installazione della versione più aggiornata non rimuove necessariamente le versioni obsolete di Java dal proprio computer, lasciando l'utente esposto al pericolo. Si dovranno, pertanto, disinstallare tutte le versioni meno aggiornate prima di procedere.

  1. Visitare questa pagina per scaricare il programma di installazione di Java aggiornato senza avviarne tuttavia l'installazione.
  2. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  3. A partire dal menu Start nella barra delle applicazioni di Windows, selezionare Pannello di controllo.

    Open Windows 7 Control Panel
  4. Aprire l'elenco dei programmi Windows.
    • (Windows Vista/7) Fare clic su Programmi e successivamente su Programmi e Funzionalità.
    • (Windows 2000/XP) Doppio clic su Installa o disinstalla programmi.
  5. Dall'elenco dei programmi attualmente installati, selezionare tutti programmi Java o Java Runtime.
  6. Disinstallazione:
    • (Windows Vista/7) Fare clic su Disinstalla nella parte superiore della finestra di Windows.
    • (Windows 2000/XP) Fare clic su Rimuovi sulla destra dell'elenco degli elementi Java.
      Nota: Completare la disinstallazione prima di procedere.
  7. Avviare il programma di installazione scaricato al punto 1.
  8. Avviare Firefox.

Java dovrebbe a questo punto funzionare come previsto.

In Firefox sono state bloccate unicamente le versioni vulnerabili di Java. È quindi opportuno effettuare l'aggiornamento alla versione più recente del plugin.

  1. Visitare questa pagina per scaricare il programma di installazione Java aggiornato.
  2. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  3. Avviare il programma di installazione scaricato al punto 1.
  4. Avviare Firefox.

Java dovrebbe a questo punto funzionare come previsto.

È necessario aggiornare Java alla versione più recente.

  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  2. Dal menu Apple, selezionare Aggiornamento Software....
  3. Selezionare l'aggiornamento Java e fare clic su Installa. Attendere il completamento dell'aggiornamento.
  4. Avviare Firefox.

Java dovrebbe a questo punto funzionare come previsto.

Se il plugin è stato inizialmente disattivato alla comparsa della finestra di avviso, potrebbe essere necessario attivare Java nuovamente:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.
  3. Individuare l'elemento Java Platform o Java Runtime e fare clic su Attiva.

Utilizzare una versione non aggiornata di Java

Qualora non fosse possibile aggiornare Java e il suo utilizzo è indispensabile, è possibile riattivare la versione obsoleta.

Avviso: questa scelta espone l'utente ad attacchi e la semplice visita ad un sito compromesso può sfruttare la vulnerabilità.

Attivare Java

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.
  3. Individuare l'elemento Java Platform o Java Runtime e fare clic su Attiva.



Condividi questo articolo: http://mzl.la/MN0qiT

Utenti che hanno contribuito a scrivere questo articolo: underpass, G-Cloud. Tutti possono contribuire.