Filelink per allegati di grosse dimensioni

Informazioni sulla versione
  • ID versione: 74542
  • Data di creazione:
  • Autore: Giulio Tripi
  • Commento: Modifiche nell'articolo originale
  • Revisionata:
  • Revisionata:
  • Revisionata da: michro
  • Approvata?
  • Versione corrente? No
  • Pronta per la localizzazione: No
Sorgente della versione
Contenuto della versione

Molti server email non accettano messaggi con allegati di grosse dimensioni. La grandezza massima del file varia in base alla configurazione del server mail. Anche se si è in grado di inviare un messaggio con un grosso allegato, questo non significa che il server mail ricevente lo accetti sicuramente. Questo processo non è controllabile da Thunderbird.

A partire da Thunderbird 13, il servizio Filelink ha eliminato questo problema aggiungendo il supporto a servizi di archiviazione online. Questo permette di caricare gli allegati su un servizio di archiviazione online e di sostituire l'allegato del messaggio con un collegamento che permette di scaricarlo. Il destinatario del messaggio può fare clic sul collegamento e scaricare l'allegato. Un altro vantaggio è che mandare e ricevere allegati di grosse dimensioni è più veloce sia per il mittente che per il destinatario, quest'ultimo risparmia anche spazio sull'account di posta.

Si noti che è possibile utilizzare il servizio Filelink in aggiunta agli allegati convenzionali. Ad esempio, puoi allegare piccoli file direttamente al messaggio e poi utilizzare Filelink per quelli di grosse dimensioni sempre nel medesimo messaggio.

Le istruzioni sotto riportate mostrano come configurare e utilizzare Filelink con Hightail (già YouSendIt), un servizio di archiviazione online. Box è un altro servizio supportato per impostazione predefinita, ma è possibile aggiungerne altri tramite l'utilizzo di componenti aggiuntivi. Al momento hubiC, AjaXplorer, FileSwap.com e ~okeanos mettono a disposizione un componente aggiuntivo per l'integrazione in Filelink.

Configurare Filelink

Per utilizzare Filelink, è necessario creare un nuovo account (o configurarne uno esistente) su uno dei servizi di archiviazione online sopra elencati.

Nella parte superiore della finestra di Thunderbird, fare clic sul menu Strumenti e selezionare OpzioniDalla barra dei menu, fare clic sul menu Thunderbird e selezionare PreferenzeNella parte superiore della finestra di Thunderbird, fare clic sul menu Modifica e selezionare Preferenze oppure fare clic sul pulsante dei menu New Fx Menufx57menu e scegliere OpzioniPreferenze. Fare clic sul pulsante Allegati, successivamente fare clic su In uscita. Selezionare il fornitore del servizio desiderato dall'elenco, fare clic sul pulsante Aggiungi. Inserire il nome utente del proprio account o fare clic sul collegamento per creare un nuovo account sul servizio di archiviazione online desiderato.


Filelinkdialog-ita

Se si decide di creare un nuovo account, si aprirà una finestra del browser che mostrerà la pagina di registrazione del servizio scelto. Creare un account come indicato, successivamente il servizio di archiviazione invierà una mail per confermare la registrazione. Per attivare l'account, fare clic sul collegamento di conferma presente nel messaggio ricevuto. Inserire il proprio nome utente (il proprio indirizzo di posta elettronica) nella finestra mostrata nell'immagine soprastante e inserire la propria password quando richiesto.

Nel pannello di configurazione principale, è possibile verificare il valore di Offrire la condivisione per file più grandi di... e specificare la grandezza del file (in megabytes) sopra la quale si desidera che Thunderbird suggerisca di utilizzare Filelink quando un allegato supera la grandezza specificata.

Utilizzare Filelink

Quando si allega un file a un messaggio, se la grandezza del file supera il valore specificato sopra, Thunderbird suggerirà automaticamente di utilizzare il servizio Filelink.

Per forzare l'uso di Filelink (piuttosto che affidare a Thunderbird il compito di determinare se la dimensione del file supera quella specificata), è possibile fare clic sulla freccia vicina al pulsante Allega sulla barra dei messaggi per accedere al menu delle opzioni di Filelink. A questo punto spostare il puntatore del mouse su Filelink e successivamente selezionare il proprio servizio preferito.

Fare clic sul pulsante collegamento per caricare il file sul servizio di archiviazione online. In alternativa fare clic Ignora per allegare il file come allegato convenzionale.


FilelinkRichiesta

Quando si preme su collegamento il messaggio mostrato diventerà


FilelinkAttendere

Quando il processo è completato, l'allegato è stato caricato sul servizio di archiviazione online. L'email sarà trasformata in un blocco di testo e un link verrà aggiunto al corpo del messaggio come mostrato nell'immagine sottostante.


FileLinkCompletato

Quando il destinatario riceve il messaggio, vedrà il collegamento e premendo su di esso scaricherà l'allegato.

Risposte alle domande più frequenti su Filelink

Gli allegati inviati con Filelink non sono salvati sui server di Mozilla. Ogni servizio di archiviazione dei dati online ha la sua politica sulla privacy e i suoi termini di servizio. Il fornitore di servizi di archiviazione dei file online ha esaminato la funzione FileLink per assicurarsi che sia coerente con la sua politica sulla privacy.

D: Mozilla conosce quale fornitore di servizi è stato scelto dall'utente?

R: No. Mozilla è all'oscuro di quale fornitore di servizi è stato scelto dall'utente. La configurazione è salvata sul PC dell'utente.

D: Quali sono i servizi di archiviazione attualmente supportati?

R: Al momento del rilascio di Thunderbird 16, Mozilla ha raggiunto accordi con Box e Hightail per integrare i loro servizi direttamente dentro Thunderbird. È possibile aggiungere il supporto di altri servizi con appositi componenti aggiuntivi, come:

R: A meno che i propri file non vengano cifrati prima del caricamento, il servizio di archiviazione potrà vedere il file così come chiunque ottenga il link dell'allegato. L'utente deve decidere da solo di quale fornitore di servizi fidarsi (i fornitori di servizi generalmente spiegano i diritti sulla privacy dell'utente nei loro termini di servizio). Occorre considerare che neanche gli allegati convenzionali sono cifrati. Quando si invia un allegato con la funzione normale, il file può essere visto da chiunque può accedere al messaggio nel passaggio dal proprio computer al server destinatario (come ad esempio il proprio fornitore di servizi di posta elettronica). Filelink ha aggiunto alcune sicurezze: durante il caricamento del file nel server del servizio di archiviazione online, questo viene cifrato tramite HTTPS, il protocollo di trasmissione sicura.

D: Per quanto tempo i file saranno disponibili sul sito del fornitore del servizio di archiviazione?

R: Il file rimarrà disponibile sul sito di archiviazione finché non sarà eliminato manualmente dall'utente che ha inviato il messaggio. È sufficiente effettuare l'accesso nel sito web del fornitore del servizio di archiviazione per visualizzare ed eliminare i file salvati.

D: Mozilla può supportare il servizio X o il protocollo Y?

R: Mozilla ha intenzione di estendere il supporto anche a SpiderOak. Mozilla ha anche un progetto disponibile ("Up-for-grabs") se qualcuno desidera aggiungere il supporto per più servizi o protocolli. La documentazione per sviluppatori per la funzione FileLink può essere consultata a questo link: https://developer.mozilla.org/en/Thun.../Filelink_Providers.

D: A diversi utenti potrebbe non piacere l'idea di salvare i loro file su servizi di terze parti come questi. Gli allegati normali continueranno a funzionare?

R: Gli allegati tradizionali continueranno a funzionare come sempre. Mozilla ha soltanto fornito la possibilità di caricare file di grosse dimensioni da qualche altra parte, se lo si desidera. Il concetto di file di grosse dimensioni di Thunderbird è di 1 MB, ma può essere regolato nelle preferenze di Thunderbird. Nella parte superiore della finestra di Thunderbird, fare clic sul menu Strumenti e selezionare OpzioniDalla barra dei menu, fare clic sul menu Thunderbird e selezionare PreferenzeNella parte superiore della finestra di Thunderbird, fare clic sul menu Modifica e selezionare Preferenze oppure fare clic sul pulsante dei menu New Fx Menufx57menu e scegliere OpzioniPreferenze. L'opzione di caricamento del file può essere anche disattivata completamente.