Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Cari Bantuan

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

opening a link in a new tab

more options

Instead of opening a link in a new tab, now when I click on a link a new window opens. How do I stop this and set up the system to open links in a new tab instead?

Instead of opening a link in a new tab, now when I click on a link a new window opens. How do I stop this and set up the system to open links in a new tab instead?

Solusi terpilih

Is the checkbox on the Options page not working? In case it wasn't clear from the article Scribe linked to, that is here:

"3-bar" menu button (or Tools menu) > Options > General

Check the box for "Open new windows in a new tab instead"

That will take care of most links that target a new window. If the site is using a script to remove features from the window or specify the size of the window, then you need to change a hidden setting to also divert those windows to a tab, but please try the regular setting first and see whether that solves it.

Baca jawaban ini dalam konteks 👍 2

Semua Balasan (3)

more options

Hi, Firefox opens links in the same tab by default. See - Use tabs to organize lots of websites in a single window.

You can open a link in a new tab by right click > Open Link In New Tab. Or, hold down Ctrl while left clicking. Or, click the mouse wheel.

You can also try the add-on Open Link in New Tab.

Another add-on is Tab Mix Plus.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

Thanks. The issue is that instead of opening a link in a new tab, Firefox consistently opens a new window. It did it when I clicked "reply" to your message, for example. This is what I'm trying to change. I'd like to go back to the standard, default new tab option.

more options

Solusi Terpilih

Is the checkbox on the Options page not working? In case it wasn't clear from the article Scribe linked to, that is here:

"3-bar" menu button (or Tools menu) > Options > General

Check the box for "Open new windows in a new tab instead"

That will take care of most links that target a new window. If the site is using a script to remove features from the window or specify the size of the window, then you need to change a hidden setting to also divert those windows to a tab, but please try the regular setting first and see whether that solves it.