Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wannan tattunawa ta zama daɗaɗɗiya. Yi sabuwar tambaya idan ka na bukatar taimako.

change page up / page down settings

  • 8 amsoshi
  • 3 sa na da wannan matsala
  • 4 views
  • Amsa ta ƙarshe daga ithinktfiam

more options

I'm in W10. When I use the page up & page down keys, windows seem to scroll more than a page. I searched and found a site's suggestion to change the default y scrolling. I looked and it was already 100. that might just have to do with the scroll wheel.

What config needs to change to work with the keys on a standard keyboard, to change their page scrolling distance?

I'm in W10. When I use the page up & page down keys, windows seem to scroll more than a page. I searched and found a site's suggestion to change the default y scrolling. I looked and it was already 100. that might just have to do with the scroll wheel. What config needs to change to work with the keys on a standard keyboard, to change their page scrolling distance?

All Replies (8)

more options

Does the same happen when you press the Space bar?


To be sure, you can check this setting:

You may have switched on caret browsing.

You can toggle caret browsing on/off by pressing F7 (Mac: fn + F7).

  • Options/Preferences -> Advanced -> General -> Accessibility: [ ] "Always use the cursor keys to navigate within pages"

Note that this is an accessibility feature of Firefox.

more options

Nope, caret browsing still false.

more options

Found this, but it's an older solution: http://forums.mozillazine.org/viewtopic.php?f=38&t=1832245

more options

Does that work for you?

If you want a specific line count then use code like this:

MAX = 20;
for(i = MAX;i > 0 ; i--){ goDoCommand('cmd_scrollLineDown'); }
MAX = 20;
for(i = MAX; i > 0; --i){ goDoCommand('cmd_scrollLineUp'); }

You can also use the PrefBar extension to create a button with this code and assign a shortcut.

more options

Fizix: Do you know if that can be added to about:config, or is it too old for safety?

Cor-el: I'm not in the least interested in code. Configuration settings are one thing, but ease of use matters.

more options

There are no prefs to set the scroll amount for a full page, only for normal scrolling with the mouse wheel or keyboard.

more options

It looks like you'd need to use the most recent version of the Keyconfig extension Dorando Keyconfig, and paste the line of code provided into it, to adjust the scroll distance. Adjusting the -50 to -130 seemed to solve the issue for the original poster there.

window.content.document.getElementsByTagName('html')[0].scrollTop+=window.content.document.getElementsByTagName('html')[0].clientHeight-50;

An gyara daga ABitMore1024

more options

I just noticed something that changes the context of the problem. It was noticed in using Page Down on Indeed pages. What I just noticed is that on LinkedIn, the pages seem to Page Down almost exactly a page. The two different sites are acting differently.

Does that sound link Indeed is just interpreting the instruction from Firefox incorrectly, and sending a bad scroll back to the FF client?