Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since I downloaded 4, my search bar does not work. It forces me to use the yahoo search window. I prefer google so have to go to Googles website to search. Kind of a pain.

  • 5 replies
  • 27 have this problem
  • 3 views
  • Last reply by Xircal

more options

The search window next to the address bar does not function. I select my preference for search, type something in, press the search icon or enter and it doesn't go anywhere. The yahoo search window below works but I have to to Google's website if I want to use their search. It happened when I updated to FireFox 4 and has been like that ever since.

The search window next to the address bar does not function. I select my preference for search, type something in, press the search icon or enter and it doesn't go anywhere. The yahoo search window below works but I have to to Google's website if I want to use their search. It happened when I updated to FireFox 4 and has been like that ever since.

All Replies (5)

more options

Follow these steps please.

  1. In the location bar at the top, type about:config and hit Enter
  2. In the filter at the top, type keyword.URL
  3. Double click it and replace it with http://www.google.com/search?q=
  4. Close Firefox via File | Exit
  5. Restart Firefox and go to the page you want as your homepage.
  6. Click Tools | Options | General
  7. Make sure it says "Show My Homepage" in the dropdown menu at the top and then click the button called "Use Current Pages".

Should work.

EDIT: revised instructions for keyword.URL to display http://www.google.com/search?q=

Modified by Xircal

more options

Good directions but when I entered keyword:URL nothing was in the box to double click. Followed through anyway. Search bar still doesn't work. Only the one on the Yahoo tool bar.

more options

Sorry, but I'm not quite sure if that's a typing error on your part (where you've typed: keyword:URL instead of keyword.URL) or whether the about:config entry looks the same as the one you see in the screenshot I've just uploaded for you?

If it looks like the one in the image, then that's OK.

more options

Firefox 4 - google search bar doesn't work. Other work - reason being the redirect happening for folks out of USA (like, for folks in India, google.com redirects the user to google.co.in)

Go to c:\program files\mozilla firefox\searchplugins\google.xml

Change the google.com to google.co.in (or the local google site)

This change will make the google search bar in f4 to work.

GK

Modified by gkondal

more options

Please read this article on how to change the search engine in the keyword.URL setting in about:config http://kb.mozillazine.org/Keyword.URL