Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Keep me logged in

  • 1 reply
  • 1 has this problem
  • 1007 views
  • Last reply by FredMcD

more options

When logging in to cmx.weightwatchers.com, I enter my username and password and click keep me logged in. Each time I go to their website, it still asks for my username and password. All other websites that I request to keep me logged in works fine, but this one doesn't. What can I do to correct it so that I don't have to enter all the information to get logged into that account?

When logging in to cmx.weightwatchers.com, I enter my username and password and click keep me logged in. Each time I go to their website, it still asks for my username and password. All other websites that I request to keep me logged in works fine, but this one doesn't. What can I do to correct it so that I don't have to enter all the information to get logged into that account?

Chosen solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac