Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 5 replies
  • 5 have this problem
  • 26 views
  • Last reply by tyrox92

more options

Hey my firefox continues to crash over and over again. Sometimes i can surf hours sometimes just minutes before crash. I dont do anything specific to get this crash on. If i watch videos on youtube. If i watch pictures. if i search google... so no specific way to cause this. Even in save-mode the firefox crashes after a while.

Hey my firefox continues to crash over and over again. Sometimes i can surf hours sometimes just minutes before crash. I dont do anything specific to get this crash on. If i watch videos on youtube. If i watch pictures. if i search google... so no specific way to cause this. Even in save-mode the firefox crashes after a while.

Chosen solution

You mention YouTube, but your plugins list doesn't show Adobe's Shockwave Flash plugin. Are you using an alternate player for Flash media??


Could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, has the situation improved?

Read this answer in context 👍 2

All Replies (5)

more options

We're sorry to hear that your Firefox seems to be crashing. Please perform the following steps to give us a crash report ID that helps us find out more about the cause of the crash.

  1. Enter about:crashes in the Firefox location bar (that's where you enter your website names) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the most recent 5 report IDs that you see in the crash report window and paste them into your forum response.

Thanks in advance for your help!

More information and further troubleshooting steps can be found in the Troubleshoot Firefox crashes (closing or quitting unexpectedly) article.

more options

Here the 5 IDs

  • bp-7b5dd391-6996-49c0-a957-e0a7a2120821
  • bp-bb357827-a0a8-48f0-b82d-3a7712120821
  • bp-4afdb440-9a82-4eb9-b208-e68062120820
  • 0066db29-0107-4377-91d5-dd921196685e
  • c22f217d-5ff9-40fb-b6ae-3d66a7e87180

Modified by cor-el

more options

As I can see, you didn't send to Mozilla the crash reports. Anyway, as I see, you have too many extensions. Maybe you'd have to reset Firefox.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Chosen Solution

You mention YouTube, but your plugins list doesn't show Adobe's Shockwave Flash plugin. Are you using an alternate player for Flash media??


Could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, has the situation improved?

more options

Hey your answer solved my problem. I disabled hardware acceleration and deleted some unused Plugins. I didnt experienced any crashes for 5 hours now. Looks like firefox is stable again. Thanks alot for your time and your help you guys are awesome.

Greetings, Tyrox

Modified by tyrox92