Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I turn off the safe search feature new in Firefox 14?

  • 4 respostas
  • 6 have this problem
  • 351 views
  • Last reply by h355930

more options

I don't want to get the secure site warning on a simple Google search...is there an about:config? And I don't want to turn the pop-up warning off, as I prefer that to having to keep checking the address bar.

I don't want to get the secure site warning on a simple Google search...is there an about:config? And I don't want to turn the pop-up warning off, as I prefer that to having to keep checking the address bar.

Chosen solution

Well, you should have mentioned that you were using the address bar the first time around. ;-)

Try this:

(1) Copy the following URL:


http://www.google.com/search?ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=fflb&q=

(2) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(3) In the filter box, type or paste keyword and pause while the list is filtered

(4) Double-click the keyword.URL preference and paste the above search URL. Click OK.

Switch to another tab and test. Fixed?

Ler a resposta no contexto 👍 3

All Replies (4)

more options

If you do not want to use HTTPS when using the search box, check out this thread: remove google https 14.0.1.

more options

This thread does not help...first, the Google quick search option for the search box wasn't on the linked page mentioned. Also, I was looking for a config option to change the address bar itself, if available. Thanks though.

more options

Chosen Solution

Well, you should have mentioned that you were using the address bar the first time around. ;-)

Try this:

(1) Copy the following URL:


http://www.google.com/search?ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=fflb&q=

(2) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(3) In the filter box, type or paste keyword and pause while the list is filtered

(4) Double-click the keyword.URL preference and paste the above search URL. Click OK.

Switch to another tab and test. Fixed?

more options

Aha, very good. I have changed this setting in the past in about:config, but I thought there was a new setting in FF 14 to not use a secure connection for a simple Google search from the address bar. I did not consider the possibility of a customized Google address for the keyword.URL setting. Thanks.