Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Location-aware browsing won't turn off!! Google is tracking me!

  • 6 replies
  • 78 have this problem
  • 647 views
  • Last reply by cor-el

more options

I followed the directions to turn off location-aware browsing: about:config geo:enabled double-click to turn off. Yet google is still able to identify my location. I have no google tool bar and I specifically turned off my location share for google in the tools page info menu. Yet they can still identify my browsing location! How do I turn it off!?

All Replies (6)

more options

Websites can do a reverse DNS lookup of your IP to get your location.

more options

I have just done the double click and it hasn't worked either. I am working in France and want to search .co.uk and it just sends me french sites. utterly pointless and completely against privacy rights. I'm just getting totally fed-up with ads that "think" they know what I want to look at and in fact are getting on my nerves so I won't buy with those companies - this is not right and its not working - please tell me how to turn it off. I'd like to know urgently.

more options

I work in Thailand and I don't want Thai results. I just want google.com, but it keeps giving me google.co.th no matter what I do! I have turned off location awareness in firefox per the instructions to no avail. I ABSOLUTELY DO NOT WANT THAI SEARCH RESULTS!!!

Modified by dkstoney

more options

There should be a link at the bottom of a local Google site to go to the Google.com website or use http://www.google.com/ncr

You need to create an allow exception to keep cookies for Google to save that setting, otherwise you have to repeat it.

  • Tools > Page Info > Permissions
  • Tools > Options > Privacy > Cookies: Exceptions
more options

Thank you, cor-el. The first link, at the bottom of Google's page, only took me to "co.th". It didn't matter whether I deleted all the cookies or manually typed in ".com". However, the 2nd "ncr" link did the trick. Many thanks for such a very quick and fine response!

Modified by dkstoney

more options

You're welcome