Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Second and next windows opened don't show full size

  • 4 respostas
  • 1 has this problem
  • 10 views
  • Last reply by zeroknight

more options

This issue started with a (frustrating) set of steps following a page which wasn't displayed (https://www.ziggogo.tv/) - the screen remained black. Refresh solved it but the reinstalled plugins didn't show an icon and did not work at all. I de-installed Firefox, installed some old version from an update, installed all plugins and then updated to the latest version. Now finally everything seems to work- except that the 2nd and next windows show at a quarter of the size compared to the first whchi show correctly. I've tried everything I could think of with xulstore.json in the correct ..\AppData\Roaming\Mozilla\Firefox\Profiles\ subdirectory but nothing helps. I deleted it (which requires you to re-check that you want a menu bar),when I though for a moment it worked, made it read only (which means Firefox makes a .tmp version of it), manually changed the content (e.g. to "main-window":{"screenX":"4","screenY":"4","width":"3840","height":"2048","sizemode":"maximized"}}} matching my 4K monitor but nothing helps. And no, Ctrl click the Close button doesn't help either.

I suspect that it is a (maybe reintroduced) bug in a later build. I don't update often and I haven't seen this issue before.

Anything I can do which I haven't tried?

This issue started with a (frustrating) set of steps following a page which wasn't displayed (https://www.ziggogo.tv/) - the screen remained black. Refresh solved it but the reinstalled plugins didn't show an icon and did not work at all. I de-installed Firefox, installed some old version from an update, installed all plugins and then updated to the latest version. Now finally everything seems to work- except that the 2nd and next windows show at a quarter of the size compared to the first whchi show correctly. I've tried everything I could think of with '''xulstore.json '''in the correct ..\AppData\Roaming\Mozilla\Firefox\Profiles\ subdirectory but nothing helps. I deleted it (which requires you to re-check that you want a menu bar),when I though for a moment it worked, made it read only (which means Firefox makes a .tmp version of it), manually changed the content (e.g. to "main-window":{"screenX":"4","screenY":"4","width":"3840","height":"2048","sizemode":"maximized"}}} matching my 4K monitor but nothing helps. And no, Ctrl click the Close button doesn't help either. I suspect that it is a (maybe reintroduced) bug in a later build. I don't update often and I haven't seen this issue before. Anything I can do which I haven't tried?

Chosen solution

I've seen this problem posted here multiple times and (for most posters) without a a working solution. I've found the cause. Firefox introduced an option to prevent tracking a site visitor apart from cookies. You can enable that via about:config with:

privacy.resistFingerprinting true

I thought I had this on earlier but in short: having this set to true caused serious problems in a few sites (for which a warning is issued in articles about this setting) but it also caused the screen not maximizing. This is a bit odd. I reversed it to false and my problem was solved.

This may mean an update is causing these trouble while an earlier version didn't (if I am right that I always had it set to true earlier, without these problems. And I update only a few times a year, as updates often cause trouble).

It seems to me that there is not enough expertise as this post did not get a reply from Firefox developers knowing what the above setting can cause.

Ler a resposta no contexto 👍 0

All Replies (4)

more options

The Ziggo GO site will fail with a black screen if WebAssembly is disabled (javascript.options.wasm set to false in about:config).

Extensions won't appear in the toolbar if they have not been pinned or they don't have permission to run in private windows.

Make sure you close Firefox completely before deleting the xulstore.json file.

Helpful?

more options

Thanks for your reply. I make a note of changes I apply in about:config and WebAssembly isn't one of them; maybe there's another cause it may have been disabled (which I can't check anymore after the reinstall). I checked the permission for private windows for each extension and I actually did the same on the reinstall and this time they appeared in the toolbar correctly. The first time I indeed tried to pin them by using Customize Toolbar, but extension were (and still aren't) there to be dragged to the toolbar to pin them. As the reinstall eventually fixed it it's also here difficult to say why the refresh didn't show them.

Yes, I closed Firefox for sue with all the attempts to let Firefox open full screen. As a matter of fact, the situation worsened and the program now also has to be maximized on the first start.

One would say it shouldn't be so difficult to open a window maximized... Any other suggestions?

Helpful?

more options

Chosen Solution

I've seen this problem posted here multiple times and (for most posters) without a a working solution. I've found the cause. Firefox introduced an option to prevent tracking a site visitor apart from cookies. You can enable that via about:config with:

privacy.resistFingerprinting true

I thought I had this on earlier but in short: having this set to true caused serious problems in a few sites (for which a warning is issued in articles about this setting) but it also caused the screen not maximizing. This is a bit odd. I reversed it to false and my problem was solved.

This may mean an update is causing these trouble while an earlier version didn't (if I am right that I always had it set to true earlier, without these problems. And I update only a few times a year, as updates often cause trouble).

It seems to me that there is not enough expertise as this post did not get a reply from Firefox developers knowing what the above setting can cause.

Helpful?

more options

privacy.resistFingerprinting has always limited the size of new windows. You can override this with an extension like Maximize All Windows (on Startup).

Alternatively you can use the new fingerprinting protection which allows selectively disabling protection features:

privacy.fingerprintingProtection = true
privacy.fingerprintingProtection.overrides = +AllTargets,-RoundWindowSize

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.