On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

No H.264/mp4 video playback (FF57x64 Win10Home)

  • 4 réponses
  • 8 ont ce problème
  • 522 vues
  • Dernière réponse par kkkkzk

more options

I can't play videos on Facebook.

I am using Firefox 57.0.4 x64.

Firefox console says:

No decoders: video/mp4; codecs="avc1.4d401e", video/mp4; codecs="avc1.4d401e", video/mp4; codecs="avc1.4d401e", video/mp4; codecs="avc1.4d401f", video/mp4; codecs="avc1.4d401f", audio/mp4; codecs="mp4a.40.5", video/mp4; codecs="avc1.42E01E mp4a.40.2", video/mp4; codecs="avc1.4D401E mp4a.40.2", video/mp4; codecs="avc1.4D401F mp4a.40.2", video/mp4; codecs="avc1.640032 mp4a.40.2", video/mp4; codecs="avc1.640033 mp4a.40.2"

Youtube html5 test says no H.264 and no MSE & H.264.

I'm on Windows 10 Home WITHOUT any "N"-s, so that Windows Media Feature Pack would be missing.

I have tried all solutions presented to similar problems. None of them worked.

How can I make it work?

I can't play videos on Facebook. I am using Firefox 57.0.4 x64. Firefox console says: No decoders: video/mp4; codecs="avc1.4d401e", video/mp4; codecs="avc1.4d401e", video/mp4; codecs="avc1.4d401e", video/mp4; codecs="avc1.4d401f", video/mp4; codecs="avc1.4d401f", audio/mp4; codecs="mp4a.40.5", video/mp4; codecs="avc1.42E01E mp4a.40.2", video/mp4; codecs="avc1.4D401E mp4a.40.2", video/mp4; codecs="avc1.4D401F mp4a.40.2", video/mp4; codecs="avc1.640032 mp4a.40.2", video/mp4; codecs="avc1.640033 mp4a.40.2" Youtube html5 test says no H.264 and no MSE & H.264. I'm on Windows 10 Home WITHOUT any "N"-s, so that Windows Media Feature Pack would be missing. I have tried all solutions presented to similar problems. None of them worked. How can I make it work?

Solution choisie

None of these did work either. I have wasted so much time on troubleshooting this it turned out that formatting C: was a faster solution :(.

Anyway, thanks for your help!

Lire cette réponse dans son contexte 👍 1

Toutes les réponses (4)

more options

Thanks for the answer.

Maybe I've constructed that sentence in a weird way, but what I meant was that it is a regular Windows version, with the Windows Media Features installed, so that solution you suggested won't do anything.

more options

Some people have had issues with HTML5 player on Youtube and other sites due to extensions like Youtube Flash or force HTML5 player or such installed in Firefox.

Type about:config with a : in Location (address) bar and make sure none of the below Preferences are user set, if any are then double-click them to restore the default value of true

  • media.mediasource.enabled
  • media.mediasource.mp4.enabled
  • media.mp4.enabled
  • media.ogg.enabled
  • media.webm.enabled

After this try the https://www.youtube.com/html5 page again.

Modifié le par James

more options

Solution choisie

None of these did work either. I have wasted so much time on troubleshooting this it turned out that formatting C: was a faster solution :(.

Anyway, thanks for your help!