Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

DRM addons not loading after upgrade to Firefox 64bit from Firefox 32bit

  • 3 replies
  • 1 has this problem
  • 38 views
  • Last reply by zeroknight

more options

After a crash earlier today within my 32bit install of Firefox, I upgraded to the 64bit version. Since then I have not been able to play videos from sites that utilize DRM.

I have tried the following:

  1. Check and Uncheck "Play DRM content"
  2. Check for updates while in the addons related page.
  3. Checked my hosts file which is blank
  4. Stopped my AV and attempted to update as well as Enable/Disable Play DRM
  5. Get a 404 when attempting to go to "redirector . gvt1 . com" site.

When I looked in my profile directory, I noted that both the "gmp-gmpopenh264" and "gmp-widevinecdm" directories are empty. I found and downloaded the most recent openh264 dll for windows 64bit. Firefox continues to say "OpenH264 Video Codec provided by Cisco Systems, Inc. will be installed shortly." I have not found the most recent wildevine version so I have not tried to update it manually.

Could there be something squirrelly with my user profile that needs to be rebuilt? (I can export the bookmarks, etc) The 32bit Firefox crashed with no messages while watching a live YouTube stream. I just installed over without uninstalling the previous version. I was afraid of losing my current settings. The crash caused my "previous session" to be lost.

After a crash earlier today within my 32bit install of Firefox, I upgraded to the 64bit version. Since then I have not been able to play videos from sites that utilize DRM. I have tried the following: # Check and Uncheck "Play DRM content" # Check for updates while in the addons related page. # Checked my hosts file which is blank # Stopped my AV and attempted to update as well as Enable/Disable Play DRM # Get a 404 when attempting to go to "redirector . gvt1 . com" site. When I looked in my profile directory, I noted that both the "gmp-gmpopenh264" and "gmp-widevinecdm" directories are empty. I found and downloaded the most recent openh264 dll for windows 64bit. Firefox continues to say "OpenH264 Video Codec provided by Cisco Systems, Inc. will be installed shortly." I have not found the most recent wildevine version so I have not tried to update it manually. Could there be something squirrelly with my user profile that needs to be rebuilt? (I can export the bookmarks, etc) The 32bit Firefox crashed with no messages while watching a live YouTube stream. I just installed over without uninstalling the previous version. I was afraid of losing my current settings. The crash caused my "previous session" to be lost.

Chosen solution

Did you create a new profile when you switched the versions ?

See "Creating a profile":

This is a link to the built-in fallback Widevine CDM files that redirect to the actual file.

media.gmp-widevinecdm.enabled => true
media.gmp-widevinecdm.visible => true
media.gmp-widevinecdm.version => needs to match installed Widevine version in gmp-widevinecdm/xxx
Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Did you create a new profile when you switched the versions ?

See "Creating a profile":

This is a link to the built-in fallback Widevine CDM files that redirect to the actual file.

media.gmp-widevinecdm.enabled => true
media.gmp-widevinecdm.visible => true
media.gmp-widevinecdm.version => needs to match installed Widevine version in gmp-widevinecdm/xxx

Helpful?

more options

These links were very helpful. I was able to recover history, bookmarks, etc using details from the "recovering important data" link. I do wish there was an easier way to recover extensions from old to new profiles. I read about FEBE and MozBack (sp?) and they both appear to be outdated. I was able to manually copy the extensions folders and extension json files from old to new profile. Then in the new profile I disable and enabled each of the extensions which seemed to allow them to be "seen" and used by Firefox. Not sure where the properties for some of the extensions are stored but I'll admit laziness here and slowly recreate the settings as I go. (NoScript and UBlock for instance)

Do you have a method to recover extensions / add-ons short of re-installing them? Is there a default path where extensions store their settings by default I might check?

Helpful?

more options

Extension settings are stored with unique identifiers that only work in that profile. Often there is an import/export feature for those that have many settings.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.