Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can Firefox 22.0 run on Mac 10.5.8 (Leopard) since it has i386 code?

  • 7 replies
  • 1 has this problem
  • 473 views
  • Last reply by James

more options

Firefox 22.0 has 1386 code (as well as x86_64), and the only difference within Info.plist is basically LSMinimumSystemVersion being 10.6 instead of 10.5 as in Firefox 16.0.2. So why can't Firefox 22.0 run of Leopard (10.5.8) with simple changes to Version numbers?

I have an Intel Mac-Mini core duo running Leopard, and an Intel Macbook Pro core 2 duo running Snow Leopard. I'd like to run Firefox 22.0 on my Mac-Mini, just as I do on my Macbook Pro, but with i386 code, which is built-in to Firefox 22.0. Currently I can only run Firefox 16.0.2 on my Mac-Mini, also using i386 code.

Firefox 22.0 has 1386 code (as well as x86_64), and the only difference within Info.plist is basically LSMinimumSystemVersion being 10.6 instead of 10.5 as in Firefox 16.0.2. So why can't Firefox 22.0 run of Leopard (10.5.8) with simple changes to Version numbers? I have an Intel Mac-Mini core duo running Leopard, and an Intel Macbook Pro core 2 duo running Snow Leopard. I'd like to run Firefox 22.0 on my Mac-Mini, just as I do on my Macbook Pro, but with i386 code, which is built-in to Firefox 22.0. Currently I can only run Firefox 16.0.2 on my Mac-Mini, also using i386 code.

Chosen solution

Is it at all possible for you to upgrade to a newer operating system? Firefox 16 is over 3 years old and has numerous security issues that have been fixed in newer versions.

If you can't upgrade to a newer operating system, I'm not sure it's really possible to do anything. Ordinarilly, I would recommend you switch web browsers, but Chrome requires snow leopard or later as well, and the version of safari that came with leopard will be outdated at this point as well. While you could try changing LSMinimumSystemVersion in info.plist, it probably won't work, as newer versions of firefox use new functions apple introduced in the operating system.

Also, you should upgrade the version of firefox on your macbook to the latest version (38), which will work with snow leopard. You can download it from http://mozilla.org/firefox.

Read this answer in context 👍 0

All Replies (7)

more options

Chosen Solution

Is it at all possible for you to upgrade to a newer operating system? Firefox 16 is over 3 years old and has numerous security issues that have been fixed in newer versions.

If you can't upgrade to a newer operating system, I'm not sure it's really possible to do anything. Ordinarilly, I would recommend you switch web browsers, but Chrome requires snow leopard or later as well, and the version of safari that came with leopard will be outdated at this point as well. While you could try changing LSMinimumSystemVersion in info.plist, it probably won't work, as newer versions of firefox use new functions apple introduced in the operating system.

Also, you should upgrade the version of firefox on your macbook to the latest version (38), which will work with snow leopard. You can download it from http://mozilla.org/firefox.

more options

So user293, it's "Firefox 22.0 uses new functions apple introduced in their operating system." that prevents me from running FF22 on Leopard. To me that means the i386 code in FF22 is also 10.6 dependent. Thanks.

more options

Firefox 17.0 to current has required OS X 10.6+ as the minimum.

https://www.mozilla.org/en-US/firefox/17.0/system-requirements/ https://www.mozilla.org/en-US/firefox/16.0/system-requirements/

https://blog.mozilla.org/futurereleases/2012/10/04/we-bid-you-adieu-spotted-cat/

As you have a Intel and dependeing on your hardware specs you could update to 10.6.x

more options

To James, well, as I said in my original question, my Leopard system is running on an Intel Core Duo, NOT a Core 2 Duo, and Snow Leopard requires the equivalent of a Core 2 Duo, or better. So I can't upgrade my Mac-Mini, unless there's some way to replace the processor.

more options

If you were using PPC hardware then there is the third-party TenFourFox to have a more up to date option.

more options

I have PPC capability on both Leopard and Snow Leopard (Rosetta). Which version of TenFourFox would I be able to run? How do I find it on the web?

more options

Information is at http://www.floodgap.com/software/tenfourfox/ and https://code.google.com/p/tenfourfox/

Note that Plugins are not used due to being old.