Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox took over my Adobe Acrobat documents.

  • 6 replies
  • 11 have this problem
  • 35 views
  • Last reply by elzach

more options

By "taking over" I mean it changed the icons from Adobe Reader to the FF one. When I click on properties it shows that they open with Adobe Reader, and they do. When I click "change", Firefox is highlighted(!) and the "always use the selected program to open this kind of file" is greyed out and checked(!).

I went to "folder options", "file types", PDF files open with Adobe Reader, but it says "to restore these files to their default type (Firefox HTML document) click "Restore".

I kid you not folks. FF went to the registry and changed defaults for pdf files?

I believe it all started when I made FF my default browser. I went back to Chrome, made Chrome the default browser, no luck.

Thank you for any suggestions.

Chosen solution

I think that it is enough to edit the value and delete the current FirefoxHTML text, so you get an empty string value.

Read this answer in context 👍 0

All Replies (6)

more options

Hello, go to a file that you want to open as adobe reader. Like a file right click on it, then you will see (open with) should see Adobe reader if not you will have to do it this way. Choose default program then browse now find your Adobe reader. I hope this helps!

Modified by Brandon Vita

more options

If you set Firefox as the default browser and Firefox detects via a registry scan that there is currently no file handler application that handles PDF files and a few other file types then the Firefox updater/installer registers Firefox as the default application to handle these file types.

On Windows XP you can check the Windows Control Panel:

  • Control Panel > Folder Options > File Types: .pdf
  • Registry Editor:
    HKEY_CURRENT_USER\Software\Classes\.pdf\
    HKEY_CLASSES_ROOT\.pdf (Default= empty string)
more options

Thank you corel.

Yes, I went to regedit and see FirefoxHTML under "default" in both entries.

How do I change this to Adobe?

Let me say here that this is ridiculous, why would Firefox do a registry scan and alter this? The default WAS Adobe Reader before. I see it also changed oga and ogg files too. Why would a browser app change anything other than html files?

Thank you.

more options

Chosen Solution

I think that it is enough to edit the value and delete the current FirefoxHTML text, so you get an empty string value.

more options

So when I right-click on them, I choose new "key", or "string value" or? there's no delete option.

Sorry I haven't messed with registry in a long while.

more options

Thank you. I edited to show an empty string value which for some reason deleted the pdf extension from my Folder Options. I recreated it as a new extension with Adobe as the default program.

I have to say, that is one of the most bizarre situations I've seen, with a browser "taking liberties" so to speak.