Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Whenever I log into my local router, 192.168.x.x firefox always goes through two pages of asking for a security exception because of an invalid certificate.

  • 4 vastust
  • 2 on selline probleem
  • 9 views
  • Viimati vastas cor-el

more options

After confirming the exception for my router the option to remember the exception is greyed out. Every time I log into my router I have to go through those two security exception pages. Why is the option to remember the exception greyed out? How can I get firefox to remember that is OK to go ahead and connect to my router?

After confirming the exception for my router the option to remember the exception is greyed out. Every time I log into my router I have to go through those two security exception pages. Why is the option to remember the exception greyed out? How can I get firefox to remember that is OK to go ahead and connect to my router?

All Replies (4)

more options

Hello,

To find the correct solution to your problem, we need some more non-personal information from you. Please do the following:

  1. Use ONE of these methods to open the Firefox Troubleshooting Information page:
    • Click the menu button New Fx Menu, click on help Help-29 and select Troubleshooting Information.
    • Type about:support into the Firefox address bar and press the enter key.
  2. At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it.
  3. Now, go back to your forum post, right-click in the reply box and select Paste from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!

more options

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
more options

cor-el said

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).
  • Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"


This worked. Is selecting "always use private browsing mode the same as not checking it but disabling all of the options below it?

more options

Private Browsing mode only means that no data is saved to the profile folder on your hard drive. Disabling other history settings works different since you enable or disable specific settings.

Cookies use a separate in memory cookie jar and all session data is kept in memory in Private Browsing mode and purged when you end the PB mode session. Cookie exceptions still work and you can create new cookie exceptions. You can't save new passwords, but Firefox can fill previously saved passwords in a login form.