Buscar en Ayuda

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is google maps so slow on Firefox?

  • 1 respuesta
  • 14 tienen este problema
  • 18 visitas
  • Última respuesta de FredMcD

more options

Hi there,

Opening the new google maps is incredibly slow in firefox for me - every aspect from map loading, clicking on route options, waiting for the popups with info on a just-clicked place to open up - googling a place/address, clicking through from google search results into maps , and getting directions from my home location can take upwards of 3/4 minutes, but if I paste the URL into Internet Explorer it works instantly...any advice?

I just tried the recommendations here, no noticeable difference:

https://support.google.com/maps/answer/18529?hl=en

Thanks,

Mat

Hi there, Opening the new google maps is incredibly slow in firefox for me - every aspect from map loading, clicking on route options, waiting for the popups with info on a just-clicked place to open up - googling a place/address, clicking through from google search results into maps , and getting directions from my home location can take upwards of 3/4 minutes, but if I paste the URL into Internet Explorer it works instantly...any advice? I just tried the recommendations here, no noticeable difference: https://support.google.com/maps/answer/18529?hl=en Thanks, Mat

Todas las respuestas (1)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

  • Remove Cookies

Warning ! ! This will log you out of all sites you're logged in to. Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy. Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.