X
Tap here to go to the mobile version of the site.

Support Forum

Firefox dropping Mac 10.6?

Posted

I have an Intel-based Mac Mini that really works well despite it's antiquity, but I obviously need to upgrade the OS. I'd greatly appreciate it if anyone could tell me whether Firefox will be dropping support for Mac 10.6 soon? I'll spend the $25 for the Snow Leopard install disk, but if it's soon to be unsupported, I guess I'd better save the dough and put the money toward a "newer" used Mac. Hate being cheap, but finances are tight. MANY thanks for any help you might offer!

I have an Intel-based Mac Mini that really works well despite it's antiquity, but I obviously need to upgrade the OS. I'd greatly appreciate it if anyone could tell me whether Firefox will be dropping support for Mac 10.6 soon? I'll spend the $25 for the Snow Leopard install disk, but if it's soon to be unsupported, I guess I'd better save the dough and put the money toward a "newer" used Mac. Hate being cheap, but finances are tight. MANY thanks for any help you might offer!

Chosen solution

Mac OSX 10.6 still supports Firefox as of 26.0 and has been the minimum requirement 17.0 https://www.mozilla.org/en-US/firefox/26.0/system-requirements/

I have not seen any signs of a future version requiring 10.7 or newer yet that I recall and the only recent change was adding OSX 10.9 to list starting in Firefox 25.0 requirements page.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • iPhoto6
  • eMusic DLM 4.1.3.2
  • RealPlayer Plugin
  • Shockwave Flash 10.3 r183
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28

More Information

James
  • Moderator
1596 solutions 11250 answers

Chosen Solution

Mac OSX 10.6 still supports Firefox as of 26.0 and has been the minimum requirement 17.0 https://www.mozilla.org/en-US/firefox/26.0/system-requirements/

I have not seen any signs of a future version requiring 10.7 or newer yet that I recall and the only recent change was adding OSX 10.9 to list starting in Firefox 25.0 requirements page.

Mac OSX 10.6 still supports Firefox as of 26.0 and has been the minimum requirement 17.0 https://www.mozilla.org/en-US/firefox/26.0/system-requirements/ I have not seen any signs of a future version requiring 10.7 or newer yet that I recall and the only recent change was adding OSX 10.9 to list starting in Firefox 25.0 requirements page.

Modified by James

Question owner

Alright! Thank you very much for the knowledge, James. Good karma's coming your way!

Alright! Thank you very much for the knowledge, James. Good karma's coming your way!