X
Tap here to go to the mobile version of the site.

Support Forum

Firefox menus and right-click have a 3-4 sec lag only on 64 bits version

Posted

Firefox on multiple versions (tested 21 and 26 at least) has an important lag when using menus and right-clicks. When using a 32 bits version, this lag does not exist. Only when using the 64 bits version does the symptom appear. This is running on Ubuntu 10 64 bits. I don't even know where to look for, the problem appears also in Safe Mode, but does not seem to leave any trace. Thanks for pointers to solutions or educational posts, or troubleshooting tips. Cheers, xgiannak

Firefox on multiple versions (tested 21 and 26 at least) has an important lag when using menus and right-clicks. When using a 32 bits version, this lag does not exist. Only when using the 64 bits version does the symptom appear. This is running on Ubuntu 10 64 bits. I don't even know where to look for, the problem appears also in Safe Mode, but does not seem to leave any trace. Thanks for pointers to solutions or educational posts, or troubleshooting tips. Cheers, xgiannak

Chosen solution

Hello, I do not run a server terminal, but a full Ubuntu Desktop (10.10). The bug above hints to the libxcd and I don't have that library on my system BUT the problem disappeared after a reboot! I totally agree with your analysis of a problem located in the X system. Probably there can be multiple causes. So to summarise my case, I suspect something got damaged in the X server and forced it to use some fallback capability, but that capability caused the problem of delay in right-click. When I rebooted, the server restarted correctly and fresh, and the problem does not appear. Let me know if that sounds too stupid as an explanation. I'm sorry to hear other persons have the same problem. We can continue analysis for them on this thread. Thanks again and cheers, xgiannak

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • The next generation Java plug-in for Mozilla browsers.
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/Linux/en-GB/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.6 (ubufox@ubuntu.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Technologies Inc. -- ATI Radeon HD 5400 Series
  • adapterDeviceID: ATI Radeon HD 5400 Series
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: ATI Technologies Inc.
  • driverDate:
  • driverVersion: 4.1.11251 Compatibility Profile Context
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 5400 Series
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 26.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1390050537
  • places.history.expiration.transient_current_max_pages: 103852
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.soname.list: libXt.so:libXext.so
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Hi xgiannak, Thank you for posting your question.

What we know so far:

  • Ubuntu 10 64 bits
  • Tested on Firefox 21 and 26 at least
  • Right click on anything? and using menus

Troubleshooting further to find traces and what to do next:

  • Is this happening in a new profile? Profile Manager - Create, remove, or switch Firefox profiles
  • Does this happen on multiple computers?
  • What are some examples of where you right click where this happens?
  • If it is a ui, grab the Developer Tools and try Debugger or Console, are there any error messages when you reproduce the lag?

Screencast of reproducing this issue is really helpful, my favorite in screencast.com .

Ok, post back with your findings and we can see if we can dig up this issue, when we find it let's create a detailed bug! :-)

Hi xgiannak, Thank you for posting your question. What we know so far: *Ubuntu 10 64 bits *Tested on Firefox 21 and 26 at least *Right click on anything? and using menus Troubleshooting further to find traces and what to do next: *Is this happening in a new profile? [[Use the Profile Manager to create and remove Firefox profiles]] *Does this happen on multiple computers? *What are some examples of where you right click where this happens? *If it is a ui, grab the Developer Tools and try Debugger or Console, are there any error messages when you reproduce the lag? Screencast of reproducing this issue is really helpful, my favorite in screencast.com . Ok, post back with your findings and we can see if we can dig up this issue, when we find it let's create a detailed bug! :-)
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158908 answers

Note that there might be extensions and plugins installed by default in a new profile, so check "Firefox/Tools > Add-ons > Extensions & Plugins" in case there are still problems.

Note that there might be extensions and plugins installed by default in a new profile, so check "Firefox/Tools > Add-ons > Extensions & Plugins" in case there are still problems. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/Troubleshooting+plugins

Question owner

Hello and thanks a lot for your attention. I will do my best to collect all the suggested elements.

1. Profiles
TBD let me do this trial when I get out of this post.
2. Happens on a single computer, note that all my other computers are 32 bits except for a Windows 7 64 bits
3. Pretty much any menu click or right click has a lag which is variable, but still important.
4. Try Developer tools: console, below is an example of a right click. You can see a lag between seconds 44 and 48, but I don't see any meaningful error message (the ones that are there are unrelated to me, meaning that I reproduce the issue without the messages).
GET http://dis.criteo.com/pump/match.aspx [HTTP/1.1 200 OK 121ms]
23:57:44.274 GET http://image2.pubmatic.com/AdServer/Pug [HTTP/1.1 200 OK 136ms]
23:57:44.274 GET http://atemda.com/UserMatch.ashx [HTTP/1.1 200 OK 153ms]
23:57:44.274 GET http://ums.adtech.de/mapuser [HTTP/1.0 200 OK 93ms]
23:57:44.275 GET http://d.turn.com/r/dd/id/L2NzaWQvMS9jaWQvMTgxMzE0MzAvdC8w/url/http%3a%2f%2fc1.adform.net%2fserving%2fcookie%2fmatch%2f%3fparty%3d1006%26cid%3d%24!%7bTURN_UUID%7d [HTTP/1.1 302 Moved Temporarily 109ms]
23:57:44.261 Expected declaration but found '*'. Skipped to next declaration. eventi-feste-25
23:57:44.261 Unknown property 'zoom'. Declaration dropped. eventi-feste-25
23:57:44.264 Error in parsing value for 'left'. Declaration dropped. eventi-feste-25
23:57:44.265 Error in parsing value for 'top'. Declaration dropped. eventi-feste-25
23:57:48.537 GET http://s1.adform.net/Banners/2380469/2380469.gif [HTTP/1.1 200 OK 260ms]
23:57:48.538 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 146ms]
23:57:48.871 GET http://static.bakeca.it/be/public/css/img/footer_background.png [HTTP/1.1 200 OK 46ms]
23:57:48.873 GET http://static.bakeca.it/be/public/css/img/feed_s.gif [HTTP/1.1 200 OK 51ms]
23:57:48.874 GET http://static.bakeca.it/be/public/css/img/fb1.gif [HTTP/1.1 200 OK 55ms]
23:57:48.874 GET http://static.bakeca.it/be/public/css/img/tw.gif [HTTP/1.1 200 OK 60ms]
23:57:48.875 GET http://static.bakeca.it/be/public/css/img/logo_footer.png [HTTP/1.1 200 OK 493ms]
23:57:48.875 GET http://pubads.g.doubleclick.net/gampad/ads [0ms]
23:57:48.876 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 88ms]
23:57:48.876 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 68ms]
23:57:49.181 GET https://track.adform.net/Serving/TrackPoint/
23:57:49.181 GET https://secure.adnxs.com/seg
23:57:49.182
Debugger does not seem to report anything special.

I have attached a screencast where I perform a right click, then go into the button menu.
You can find it on dropbox
https://dl.dropboxusercontent.com/u/95778517/inquire983670.ogv
Let me know if you have any further idea.
Thanks
xavier

Hello and thanks a lot for your attention. I will do my best to collect all the suggested elements. 1. Profiles<br /> TBD let me do this trial when I get out of this post.<br /> 2. Happens on a single computer, note that all my other computers are 32 bits except for a Windows 7 64 bits<br /> 3. Pretty much any menu click or right click has a lag which is variable, but still important.<br /> 4. Try Developer tools: console, below is an example of a right click. You can see a lag between seconds 44 and 48, but I don't see any meaningful error message (the ones that are there are unrelated to me, meaning that I reproduce the issue without the messages).<br /> GET http://dis.criteo.com/pump/match.aspx [HTTP/1.1 200 OK 121ms]<br /> 23:57:44.274 GET http://image2.pubmatic.com/AdServer/Pug [HTTP/1.1 200 OK 136ms]<br /> 23:57:44.274 GET http://atemda.com/UserMatch.ashx [HTTP/1.1 200 OK 153ms]<br /> 23:57:44.274 GET http://ums.adtech.de/mapuser [HTTP/1.0 200 OK 93ms]<br /> 23:57:44.275 GET http://d.turn.com/r/dd/id/L2NzaWQvMS9jaWQvMTgxMzE0MzAvdC8w/url/http%3a%2f%2fc1.adform.net%2fserving%2fcookie%2fmatch%2f%3fparty%3d1006%26cid%3d%24!%7bTURN_UUID%7d [HTTP/1.1 302 Moved Temporarily 109ms]<br /> 23:57:44.261 Expected declaration but found '*'. Skipped to next declaration. eventi-feste-25<br /> 23:57:44.261 Unknown property 'zoom'. Declaration dropped. eventi-feste-25<br /> 23:57:44.264 Error in parsing value for 'left'. Declaration dropped. eventi-feste-25<br /> 23:57:44.265 Error in parsing value for 'top'. Declaration dropped. eventi-feste-25<br /> 23:57:48.537 GET http://s1.adform.net/Banners/2380469/2380469.gif [HTTP/1.1 200 OK 260ms]<br /> 23:57:48.538 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 146ms]<br /> 23:57:48.871 GET http://static.bakeca.it/be/public/css/img/footer_background.png [HTTP/1.1 200 OK 46ms]<br /> 23:57:48.873 GET http://static.bakeca.it/be/public/css/img/feed_s.gif [HTTP/1.1 200 OK 51ms]<br /> 23:57:48.874 GET http://static.bakeca.it/be/public/css/img/fb1.gif [HTTP/1.1 200 OK 55ms]<br /> 23:57:48.874 GET http://static.bakeca.it/be/public/css/img/tw.gif [HTTP/1.1 200 OK 60ms]<br /> 23:57:48.875 GET http://static.bakeca.it/be/public/css/img/logo_footer.png [HTTP/1.1 200 OK 493ms]<br /> 23:57:48.875 GET http://pubads.g.doubleclick.net/gampad/ads [0ms]<br /> 23:57:48.876 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 88ms]<br /> 23:57:48.876 GET http://c1.adform.net/serving/cookie/match/ [HTTP/1.1 200 OK 68ms]<br /> 23:57:49.181 GET https://track.adform.net/Serving/TrackPoint/ <br /> 23:57:49.181 GET https://secure.adnxs.com/seg <br /> 23:57:49.182 <br /> Debugger does not seem to report anything special.<br /> <br /> I have attached a screencast where I perform a right click, then go into the button menu.<br /> You can find it on dropbox<br /> https://dl.dropboxusercontent.com/u/95778517/inquire983670.ogv<br /> Let me know if you have any further idea. <br /> Thanks<br /> xavier

Modified by cor-el

Question owner

And yes, this seems to reproduce even with a brand new profile. Best regards, xavier g.

And yes, this seems to reproduce even with a brand new profile. Best regards, xavier g.
guigs 1072 solutions 11697 answers

Hi xavier, Thank you it looks like this bug: Bug 477068 - Context menu and drop down list are slow to appear when running on Linux Terminal Server Project (remote X) (edit) It looks like they resolved the issue by updating Ubuntu to version 11, no records of the current version 12.

Are you running the linux terminal at the same time by chance? If not I did file a new bug anyway, please feel free to add if I missed anythng: https://bugzilla.mozilla.org/show_bug.cgi?id=966057

Hi xavier, Thank you it looks like this bug: [https://bugzilla.mozilla.org/show_bug.cgi?id=477068 Bug 477068 - Context menu and drop down list are slow to appear when running on Linux Terminal Server Project (remote X) (edit) ] It looks like they resolved the issue by updating Ubuntu to version 11, no records of the current version 12. Are you running the linux terminal at the same time by chance? If not I did file a new bug anyway, please feel free to add if I missed anythng: [https://bugzilla.mozilla.org/show_bug.cgi?id=966057]

Chosen Solution

Hello, I do not run a server terminal, but a full Ubuntu Desktop (10.10). The bug above hints to the libxcd and I don't have that library on my system BUT the problem disappeared after a reboot! I totally agree with your analysis of a problem located in the X system. Probably there can be multiple causes. So to summarise my case, I suspect something got damaged in the X server and forced it to use some fallback capability, but that capability caused the problem of delay in right-click. When I rebooted, the server restarted correctly and fresh, and the problem does not appear. Let me know if that sounds too stupid as an explanation. I'm sorry to hear other persons have the same problem. We can continue analysis for them on this thread. Thanks again and cheers, xgiannak

Hello, I do not run a server terminal, but a full Ubuntu Desktop (10.10). The bug above hints to the libxcd and I don't have that library on my system BUT the problem disappeared after a reboot! I totally agree with your analysis of a problem located in the X system. Probably there can be multiple causes. So to summarise my case, I suspect something got damaged in the X server and forced it to use some fallback capability, but that capability caused the problem of delay in right-click. When I rebooted, the server restarted correctly and fresh, and the problem does not appear. Let me know if that sounds too stupid as an explanation. I'm sorry to hear other persons have the same problem. We can continue analysis for them on this thread. Thanks again and cheers, xgiannak