Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After trying all the troubleshooting options, Firefox continues lagging during most actions

  • 2 replies
  • 18 have this problem
  • 512 views
  • Last reply by iuqiddis

more options

I recently applied two updates, and I'm not sure which one caused this problem, or if its even related to either of these two updates. The first one was updating from Ubuntu 13.04 to 13.10. The second one was updating from the previous verison of Firefox to the latest stable release (26). Both upgrades were done about simultaneously, so hard to tell which is causing problems, if either.

Now, the problem. Basically, firefox lags a lot while doing most actions. If i start up firefox, it takes about 3 seconds before I can see a cursor or see text in the address bar. However, all the input appears fine once the chrome works. If i'm loading a webpage and 'Control + T' for a new tab, it lags about 3-5 seconds before the new tab appears. If I switch focus to another window, swtich back, and then scroll down, there is a 3-5 second lag before the page scrolls. This sort of delay occurs constantly.

I have gone through most( all?) the troubleshooting guides here, and a few on the mozillaline forums. I definitely know what triggers the problem. I just dont' know how to fix it. But in order of what I tried to get to my trigger:

I disabled all the add-ons. Problem remained. Disabled the plugins. Problem remained. Did safe-mode, problem remained. At this point, I swtiched over to a new profile. I installed all my add-ons, plugins one by one. Nothing triggered the problem. I spent plenty of time after each installation, and no lag at all. THEN I finally added my sync information to the new profile. Immediately upon the addition of bookmarks (I only sync bookmarks and tabs), the new profile started lagging. After 30 minutes or so, the lag became consistent, and like described above.

So I went to the guides again and tried deleting the .js file (session.js, I think) and automatic .json bookmark backups ( I placed an exported backup in the profile directory, as the instruction said) and let it reconstruct the js file. My bookmarks came back, but the lag was still there.

Then I made a 3rd new profile, and didn't add any add-ons or anything, and just added my sync information. Again it started lagging. I exported my bookmarks as html, deleted all my bookmarks, and then re-imported the html file. The lag was till there.

Then I deleted firefox, and all the profiles, and reinstalled it. I set up my sync account, and the lag came about again. And that's where I am now.

Other information that I should mention: I sync with two windows machines, and two android devices (5 including the ubuntu machine that is troubling me). The other firefoxes behave perfectly (no lag or anything).

My bookmark folder has about 2000 items. That doesn't seem too outlandish to be troublesome, and if the windows and android machines can handle it fine, so should the ubuntu machine.

When I run off terminal, I get the error 'gtk_accelerator_valid(key, modifier)' failed option, and I've tried searching/ troubleshooting that error, but they don't seem to work either.

Anything else I'm missing? Any help would be appreciated. Thanks!

All Replies (2)

more options

Did you try to delete the places.sqlite file as that is the most likely cause for issues with the bookmarks?


You can check for problems with the places.sqlite database file in the Firefox profile folder.

more options

Hey, thanks for replying.

I actually did try that and it didn't work. In my original question, where I said session.js, I really meant places.sqlite. I wrote that up without looking at my notes, so forgot the name.

Any other ideas? Is there any other way to reconstruct bokmarks? besides one to one transfer to another profile, which would take days.

Thaks for your help.