X
Tap here to go to the mobile version of the site.

Support Forum

After trying all the troubleshooting options, Firefox continues lagging during most actions

Posted

I recently applied two updates, and I'm not sure which one caused this problem, or if its even related to either of these two updates. The first one was updating from Ubuntu 13.04 to 13.10. The second one was updating from the previous verison of Firefox to the latest stable release (26). Both upgrades were done about simultaneously, so hard to tell which is causing problems, if either.

Now, the problem. Basically, firefox lags a lot while doing most actions. If i start up firefox, it takes about 3 seconds before I can see a cursor or see text in the address bar. However, all the input appears fine once the chrome works. If i'm loading a webpage and 'Control + T' for a new tab, it lags about 3-5 seconds before the new tab appears. If I switch focus to another window, swtich back, and then scroll down, there is a 3-5 second lag before the page scrolls. This sort of delay occurs constantly.

I have gone through most( all?) the troubleshooting guides here, and a few on the mozillaline forums. I definitely know what triggers the problem. I just dont' know how to fix it. But in order of what I tried to get to my trigger:

I disabled all the add-ons. Problem remained. Disabled the plugins. Problem remained. Did safe-mode, problem remained. At this point, I swtiched over to a new profile. I installed all my add-ons, plugins one by one. Nothing triggered the problem. I spent plenty of time after each installation, and no lag at all. THEN I finally added my sync information to the new profile. Immediately upon the addition of bookmarks (I only sync bookmarks and tabs), the new profile started lagging. After 30 minutes or so, the lag became consistent, and like described above.

So I went to the guides again and tried deleting the .js file (session.js, I think) and automatic .json bookmark backups ( I placed an exported backup in the profile directory, as the instruction said) and let it reconstruct the js file. My bookmarks came back, but the lag was still there.

Then I made a 3rd new profile, and didn't add any add-ons or anything, and just added my sync information. Again it started lagging. I exported my bookmarks as html, deleted all my bookmarks, and then re-imported the html file. The lag was till there.

Then I deleted firefox, and all the profiles, and reinstalled it. I set up my sync account, and the lag came about again. And that's where I am now.

Other information that I should mention: I sync with two windows machines, and two android devices (5 including the ubuntu machine that is troubling me). The other firefoxes behave perfectly (no lag or anything).

My bookmark folder has about 2000 items. That doesn't seem too outlandish to be troublesome, and if the windows and android machines can handle it fine, so should the ubuntu machine.

When I run off terminal, I get the error 'gtk_accelerator_valid(key, modifier)' failed option, and I've tried searching/ troubleshooting that error, but they don't seem to work either.

Anything else I'm missing? Any help would be appreciated. Thanks!

I recently applied two updates, and I'm not sure which one caused this problem, or if its even related to either of these two updates. The first one was updating from Ubuntu 13.04 to 13.10. The second one was updating from the previous verison of Firefox to the latest stable release (26). Both upgrades were done about simultaneously, so hard to tell which is causing problems, if either. Now, the problem. Basically, firefox lags a lot while doing most actions. If i start up firefox, it takes about 3 seconds before I can see a cursor or see text in the address bar. However, all the input appears fine once the chrome works. If i'm loading a webpage and 'Control + T' for a new tab, it lags about 3-5 seconds before the new tab appears. If I switch focus to another window, swtich back, and then scroll down, there is a 3-5 second lag before the page scrolls. This sort of delay occurs constantly. I have gone through most( all?) the troubleshooting guides here, and a few on the mozillaline forums. I definitely know what triggers the problem. I just dont' know how to fix it. But in order of what I tried to get to my trigger: I disabled all the add-ons. Problem remained. Disabled the plugins. Problem remained. Did safe-mode, problem remained. At this point, I swtiched over to a new profile. I installed all my add-ons, plugins one by one. Nothing triggered the problem. I spent plenty of time after each installation, and no lag at all. THEN I finally added my sync information to the new profile. Immediately upon the addition of bookmarks (I only sync bookmarks and tabs), the new profile started lagging. After 30 minutes or so, the lag became consistent, and like described above. So I went to the guides again and tried deleting the .js file (session.js, I think) and automatic .json bookmark backups ( I placed an exported backup in the profile directory, as the instruction said) and let it reconstruct the js file. My bookmarks came back, but the lag was still there. Then I made a 3rd new profile, and didn't add any add-ons or anything, and just added my sync information. Again it started lagging. I exported my bookmarks as html, deleted all my bookmarks, and then re-imported the html file. The lag was till there. Then I deleted firefox, and all the profiles, and reinstalled it. I set up my sync account, and the lag came about again. And that's where I am now. Other information that I should mention: I sync with two windows machines, and two android devices (5 including the ubuntu machine that is troubling me). The other firefoxes behave perfectly (no lag or anything). My bookmark folder has about 2000 items. That doesn't seem too outlandish to be troublesome, and if the windows and android machines can handle it fine, so should the ubuntu machine. When I run off terminal, I get the error 'gtk_accelerator_valid(key, modifier)' failed option, and I've tried searching/ troubleshooting that error, but they don't seem to work either. Anything else I'm missing? Any help would be appreciated. Thanks!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • The Videos 3.8.2 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/Linux/en-US/

Extensions

  • Clearly 9.3369.854.431 (readable@evernote.com)
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Edit Bookmark Plus 2.3.0 (edit-bookmark-plus@kashiif-gmail.com)
  • FireGestures 1.7.15 (firegestures@xuldev.org)
  • Flash and Video Download 1.45 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Ghostery 5.0.6 (firefox@ghostery.com)
  • Greasemonkey 1.12 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Print Edit 10.2 (printedit@DW-dev)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.8 (ubufox@ubuntu.com)
  • Unity Websites integration 2013.09.20.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Desktop
  • adapterDeviceID: Mesa DRI Intel(R) Haswell Desktop
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 9.2.1
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell Desktop
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131206145143
  • browser.startup.homepage_override.buildID: 20131206145143
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.extensions-dta: True
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17574 solutions 158975 answers

Did you try to delete the places.sqlite file as that is the most likely cause for issues with the bookmarks?


You can check for problems with the places.sqlite database file in the Firefox profile folder.

Did you try to delete the places.sqlite file as that is the most likely cause for issues with the bookmarks? ---- You can check for problems with the places.sqlite database file in the Firefox profile folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file

Question owner

Hey, thanks for replying.

I actually did try that and it didn't work. In my original question, where I said session.js, I really meant places.sqlite. I wrote that up without looking at my notes, so forgot the name.

Any other ideas? Is there any other way to reconstruct bokmarks? besides one to one transfer to another profile, which would take days.

Thaks for your help.

Hey, thanks for replying. I actually did try that and it didn't work. In my original question, where I said session.js, I really meant places.sqlite. I wrote that up without looking at my notes, so forgot the name. Any other ideas? Is there any other way to reconstruct bokmarks? besides one to one transfer to another profile, which would take days. Thaks for your help.