X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

certificates problems and images not loading

Posted

i did a fresh install of the firefox v24 on my windows 7 ultimate 64bit desktop. after installation im getting certificate security issues for almost all websites even for the firstrun page. I cannot install any websites from addon wesite because firefox says this "services.addons.mozilla.org uses an invalid security certificate." and im not able add exceptions.

If i open Facebook, only the html part is loading. No CSS or images. Please help me wtih this issue

Additional System Details

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • IDM CC 7.3.58 (mozilla_cc@internetdownloadmanager.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 3000
  • adapterDescription2: NVIDIA GeForce GT 525M
  • adapterDeviceID: 0x0116
  • adapterDeviceID2: 0x0df5
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 1024
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 8-21-2012
  • driverDate2: 9-12-2013
  • driverVersion: 9.17.10.2843
  • driverVersion2: 9.18.13.2723
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • extensions.lastAppVersion: 24.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Can you try this in a new profile, does this work?

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file.
Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.
Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

You can use this button to go to the Firefox profile folder:

Helpful Reply

The issue isn't resolved.... i tried doing a clean install... created number of new profiles using profilemanager.... but its the same....im attaching some screenshots of how facebook is opening in a clean install and new profile

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Check out why the site is untrusted (click "Technical Details to expand that section) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

Note that some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

MikeLane9143 0 solutions 1 answers

Hi All. I run Firefox 25.0.1 on a number of Win7 machines. On one of those machines only, we have started to have problems. A couple of weeks ago, that machine just started refusing to go to Google search results or to Facebook using Firefox - siting a broken chain in the certificates. IE and Chrome work fine.

Analysing this further it would appear that the certificate source that is untrusted is Bullguard DevelTeam! Now, this is not the only machine that I've been using Bullguard and Firefox on, but it is the only one with the problem.

Have tried solutions from other sites of inserting a new intermediate CA, reinstalling Firefox, using safe mode, and shutting down the firewall. None of these have worked, I have asked my wife to switch to using IE, but she prefers Firefox, and yesterday I had to troubleshoot IE because with 12 tabs open, it was chewing a massive 1.5Gb of RAM!

Now at my wits end with this one short of a complete rebuild.

dfrosty 0 solutions 1 answers

I had this same problem, and after trying everything I could with the browser, I finally found that the problem was with an antivirus software I had installed. The antivirus was substituting their own certificate in place of the default certificate for any https websites, and Firefox was blocking it as an untrusted certificate.

The antivirus software had an option under settings to "scan encrypted connections". When I disabled this option, it fixed the certificate and image loading problems.

View the certificate, and if the issuer is an antivirus software that you have installed, try looking under the antivirus settings for something that might fix the problem.