Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why Firefox doesn't remember full-screen mode?

  • 7 replies
  • 13 have this problem
  • 5 views
  • Last reply by cor-el

more options

I click on the top righ to make Firefox in a full-screen mode on my Macbook Pro OS X Mountain Lion 10.8.4 but after closing the Mac or just the browser (firefox) and then re-open it, when i clic on firefox icon on my dock it doesnt remeber to go full-screen mode.

It's a bit boring because Safari do remeber to open itself in a large full clean page.

Can anyone be so kind to help me? Thanks a lot

All Replies (7)

more options

I think is an issue with OS X 8. I have the same problem.

System Preferences > General > Uncheck "Close windows when quitting an application" works with some applications, but not with Firefox (at least for me).

more options

I don't have the answer to how to make sure the Firefox window is always maximized when you start it up. It might reduce your pain if before maximizing the window, you first stretch it as large as possible so that Firefox remembers this as the "standard" window size for the next time.

more options

Are you first closing all open windows (i.e. leave the menu bar visible) or do you use Firefox > Quit to close the Firefox application with all open windows?

Does this also happen if you switch to full screen mode (Command+Shift+F)?

more options

I already unchecked that box before posting the question, because its written in other questions here and in the Apple Forume where i put this question for the first time

more options

sorry, i don't undestand your question

cmd+shift+f works but i have to re-do this command every time i re-open the program, is that normal?

more options

i have only 13, the windows is already streched as large as it can be, but thank you

more options

You can check for problems caused by a corrupted localstore.rdf file.

Try to remove the Firefox plist file (org.mozilla.firefox.plist).

Go to "~/Library/Preferences" and remove the plist file for Firefox (org.mozilla.firefox.plist)