X
Tap here to go to the mobile version of the site.
IMPORTANT ANNOUNCEMENT: We’re going through some system changes, that may have slowed responses to your questions. If you had asked a question in the last couple of months, please re-post it and the community will help you as soon as we can. If you’ve registered after February 7th, please register again, the accounts on the previous site were not migrated to this temporary site. If you joined us before February 7, please reset your password if you have trouble logging into this temporary site.

Support Forum

How do I disable zoom?

Posted

I have set both zoom.maxPercent and zoom.minPercent to 100 (tried other values too), but I can still pinch to zoom. Have restarted FF several times, including choosing Quit from the menu, dragging it out from the running apps view, and even Force closing. Nothing helps. The settings are saved, but I can still pinch and stretch to zoom.

I have set both zoom.maxPercent and zoom.minPercent to 100 (tried other values too), but I can still pinch to zoom. Have restarted FF several times, including choosing Quit from the menu, dragging it out from the running apps view, and even Force closing. Nothing helps. The settings are saved, but I can still pinch and stretch to zoom.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

More Information

kbrosnan
  • Moderator
479 solutions 3231 answers

Zooming is a core feature of modern mobile browsers.

If you own a website you can create a mobile specific site using the correct meta-viewport options. to disable zooming.

Zooming is a core feature of modern mobile browsers. If you own a website you can create a mobile specific site using the correct meta-viewport options. to disable zooming.

Question owner

I don't have that kind of control over the DOM or markup. What I do have is absolute control over the browser, so disabling zoom there is the only solution. Is there a reason zoom.minPercent and zoom.maxPercent don't work on Firefox for Android?

I don't have that kind of control over the DOM or markup. What I do have is absolute control over the browser, so disabling zoom there is the only solution. Is there a reason zoom.minPercent and zoom.maxPercent don't work on Firefox for Android?
kbrosnan
  • Moderator
479 solutions 3231 answers

Yes. We don't use zoom. There is a 'Text Size' option in the settings. You can set that to its smallest size by pressing the small a several times then pressing 'Set'.

Yes. We don't use zoom. There is a 'Text Size' option in the settings. You can set that to its smallest size by pressing the small a several times then pressing 'Set'.