X
Tap here to go to the mobile version of the site.

Support Forum

In latest Mac, moved Firefox from "Applications" folder to "trash," then deleted "Mozilla" folder from "Application Support" folder: now no longer re-installs.

Posted

My firefox was hanging too much in my latest mac release, so I moved it from app. folder to trash folder, deleted Mozilla folder from app support folder under the Library folder, but did not find the .plist file in the Preferences folder nor anything in the Receits folder.

I then tried to reinstall firefox, but i keep getting the message of "Could not initialize the application's security component." Firefox would then just freeze and not display any websites. Would appreciate a fix for this problem, thanks!

My firefox was hanging too much in my latest mac release, so I moved it from app. folder to trash folder, deleted Mozilla folder from app support folder under the Library folder, but did not find the .plist file in the Preferences folder nor anything in the Receits folder. I then tried to reinstall firefox, but i keep getting the message of "Could not initialize the application's security component." Firefox would then just freeze and not display any websites. Would appreciate a fix for this problem, thanks!

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.17 (KHTML, like Gecko) Version/6.0.2 Safari/536.26.17

More Information

ideato
  • Top 25 Contributor
684 solutions 5030 answers
Hello Buggy.Mac, see : [https://support.mozilla.org/en-US/kb/couldnt-initialize-applications-security-component#os=mac&browser=fx17 Fix the "Could not initialize the application's security component" error message] [http://kb.mozillazine.org/Profile_folder_-_Firefox Profile folder - Firefox] thank you

Question owner

Naw, dude. Please actually read my issue before answering.

I actually figured out the problem. I first had sent the Firefox program from the "Applications" folder to "Trash." Then, I went to this folder: Macintosh HD / Library / Application Support, and from here I deleted "Mozilla" folder. I thought I was done with what must be done. I then downloaded Firefox again, but it would not install properly and gave me the "Could not initialize the application's security component" message.

After searching the internet and finding something on what I believe was either Cnet.com or Pcmag.com or something like that, I found out that I actually had to go to "Macintosh HD / Users / John Doe / Library / Application Support, and then delete the folder "Firefox." I then had to go one folder up, and arrive back to: Library. From here, I would enter "Preferences" folder and delete the .plist file with the word "firefox" in it.

Here was the trick: by default, the "Library" folder was hidden under "John Doe" folder, so I was told to go to "Macintosh HD / Applications / Utilities, and run the program called "Terminal" and enter a code to get the Library folder to show by default. I don't remember the code now, but after I ran it, I then deleted what I needed to, then re-downloaded Firefox and installed it, and it now works.

God speed, my friends!

Naw, dude. Please actually read my issue before answering. I actually figured out the problem. I first had sent the Firefox program from the "Applications" folder to "Trash." Then, I went to this folder: Macintosh HD / Library / Application Support, and from here I deleted "Mozilla" folder. I thought I was done with what must be done. I then downloaded Firefox again, but it would not install properly and gave me the "Could not initialize the application's security component" message. After searching the internet and finding something on what I believe was either Cnet.com or Pcmag.com or something like that, I found out that I actually had to go to "Macintosh HD / Users / John Doe / Library / Application Support, and then delete the folder "Firefox." I then had to go one folder up, and arrive back to: Library. From here, I would enter "Preferences" folder and delete the .plist file with the word "firefox" in it. Here was the trick: by default, the "Library" folder was hidden under "John Doe" folder, so I was told to go to "Macintosh HD / Applications / Utilities, and run the program called "Terminal" and enter a code to get the Library folder to show by default. I don't remember the code now, but after I ran it, I then deleted what I needed to, then re-downloaded Firefox and installed it, and it now works. God speed, my friends!
cor-el
  • Top 10 Contributor
  • Moderator
11981 solutions 111344 answers

Helpful Reply

In Mac OS X v10.7 and later, the $HOME/Library folder is a hidden folder.

Open Finder and use one of these:

  • Go > Go To Folder (Shift-Command-G) and in the dialog type: ~/Library
  • Open the "Go" menu and hold down the Option key to make the Library appear

You can also use this command in a Terminal window to remove the hidden flag.

  • Mac HD > Applications > Utilities > Terminal
  • chflags nohidden ~/Library
In Mac OS X v10.7 and later, the $HOME/Library folder is a hidden folder. Open Finder and use one of these: * Go > Go To Folder (Shift-Command-G) and in the dialog type: ~/Library * Open the "Go" menu and hold down the Option key to make the Library appear You can also use this command in a Terminal window to remove the hidden flag. * Mac HD > Applications > Utilities > Terminal * chflags nohidden ~/Library