X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Updating my security and stability will disable two add-ons that I use very frequently. Please advise!

Posted

I keep getting a software update for security and stability for Firefox. But it is telling me that two of my add-ons are incompatible and will be disabled. Problem is, I use these add-ons on a regular basis and I need them. I don't want to risk losing them and not being able to get them back. I don't like Explorer at all, but if there is no way around this then I will have to switch back to them which will not make me happy. I really do prefer Firefox because it is by far and away a better product. However, I also need my BitComet downloader and my Divx. What should I do here?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DivX Plus Web Player version 2.2.0.52
  • AmazonMP3DownloaderPlugin 1.0.15
  • BitCometAgent v1.27 for Firefox
  • DivX VOD Helper Plug-in
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Try to update Firefox, your extensions should work if they are working now in Firefox 9.