Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PLUG-INS not always loading - - Coupon Printer Manager plugin has crashed

  • No replies
  • 1 has this problem
  • 1 view
more options

dupe of

I am running Windows XP SP3 and all updates are current.

For weeks, running 7.0.1, 8.0.1 or 9.0.1, whenever I try to print coupons at the website, I have difficulty and consistently I receive the following Firefox ERROR message...

"The Coupons Inc. Coupon Printer Manager plugin has crashed"

...and I always SUBMIT a REPORT to Mozilla.

This website is suppose to invoke the following plug-ins...

Coupons Inc., Coupon Printer Manager Coupons Inc., Coupon Printer Manager

...and using Task Manager I watch to see if the Image column shows one or two plug-ins appear - of course, I don't know which ones - see below for additional info. Most of the time only one plug-in appears and then the website asks me to INSTALL the software (again). When two plug-ins appear (again, I do not know which), things run okay for the first coupon - however around 50% of the time I am unable to print a second, third, etc, coupon.

Regarding add-ons, I have the following:

PLUG-INS Coupons Inc., Coupon Printer Manager Coupons Inc., Coupon Printer Manager Java Deployment Toolkit 6.0.300.12 6.0.300.12 Java Platform SE 6 U30 6.0.300.12 QuickTime Plug-in 7.7 Shockwave Flash

EXTENSIONS Adblock Plus 2.0.3 Free Download Manager plugin 1.5.5

APPEARANCE FOXSCAPE 4.01 Default 9.0.1 (disabled)

I have disabled each of these add-ons to see if anything improves, but nothing does. This does not surprise me since I have been running the same ADD-ONS for months and this problem has only started happening over the past few weeks.

I have uninstalled the Coupon Printer plug-ins, scrubbed my Registry, and then reinstalled them (with FF closed, as well as opened, of course), and that does not help either.

Sure would like to RESOLVE this FF problem.

I am wondering if there's a PLUGINS setting that needs tweaking, and on that note, I have tried setting... TRUE (where default is false) and that does not help either.

The following screen shot shows my about:config / plugin details >

Hopefully, others have experienced the same problem and found a workaround or fix.


CurlySue  :o)

Modified by the-edmeister