X
Tap here to go to the mobile version of the site.

Support Forum

Why does the firefox browser insist on adding "www" to the front of my website entries? Can I shut this off?

Posted

I'm trying to access an address that does not use the "www" prefix. But when I type in the address, the search fails and suddenly, "www" appears in the "problem loading page" message. But that's not the address I need to access.

I'm trying to access an address that does not use the "www" prefix. But when I type in the address, the search fails and suddenly, "www" appears in the "problem loading page" message. But that's not the address I need to access.

Chosen solution

Are you using a proxy to connect?

  • Tools > Options > Advanced : Network : Connection > Settings

You can try to disable the fixup to prevent Firefox from try the address with a www. prefix.

See:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Shockwave Flash 10.1 r82
  • GEPlugin
  • Picasa plugin
  • 4.0.60831.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)

More Information

Swarnava Sengupta
  • Locale Leader
493 solutions 3273 answers

Upgrade your browser to Firefox 9 and check

Upgrade your browser to Firefox 9 and check * getfirefox.com
cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160047 answers

Does it work correctly if you type the full address including the protocol?

You can try to disable keyword search by setting the keyword.enabled pref to false.

Does it work correctly if you type the full address including the protocol? You can try to disable keyword search by setting the keyword.enabled pref to false. * http://kb.mozillazine.org/keyword.enabled * http://kb.mozillazine.org/Location_Bar_search * http://kb.mozillazine.org/browser.urlbar.default.behavior

Question owner

Thank you for the response.

No, I type it in as "http://att.elevate" and apparently, I've discovered that it reverts to "http://www.att.elevate" (and sometimes adds a ".com") when the site cannot be found - which is when the hotspot device is not connected - this is when the problem occurs. (The address actually directs me to a piece of local hardware, AT&T's HotSpot.) So perhaps it's not Firefox. But it's confusing when it reverts to the "www" prefix. I'm guessing that it must do that when it cannot find the device. But my primary problem now (I suppose) is that when this happens, the "www"-appended address is added to the history, and when I need to connect again, Firefox automatically adds the "www" to the address every time afterward. I keep having to clear it out of history, which gets old.

Thank you for the response. No, I type it in as "http://att.elevate" and apparently, I've discovered that it reverts to "http://www.att.elevate" (and sometimes adds a ".com") when the site cannot be found - which is when the hotspot device is not connected - this is when the problem occurs. (The address actually directs me to a piece of local hardware, AT&T's HotSpot.) So perhaps it's not Firefox. But it's confusing when it reverts to the "www" prefix. I'm guessing that it must do that when it cannot find the device. But my primary problem now (I suppose) is that when this happens, the "www"-appended address is added to the history, and when I need to connect again, Firefox automatically adds the "www" to the address every time afterward. I keep having to clear it out of history, which gets old.
cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160047 answers

Chosen Solution

Are you using a proxy to connect?

  • Tools > Options > Advanced : Network : Connection > Settings

You can try to disable the fixup to prevent Firefox from try the address with a www. prefix.

See:

Are you using a proxy to connect? *Tools > Options > Advanced : Network : Connection > Settings ----- You can try to disable the fixup to prevent Firefox from try the address with a www. prefix. See: * https://support.mozilla.org/kb/Location+bar+search#w_domain-guessing * http://www-archive.mozilla.org/docs/end-user/domain-guessing.html

Question owner

Not using a proxy. Thank you so much for providing the answer. That's what I was looking for!!

Not using a proxy. Thank you so much for providing the answer. That's what I was looking for!!