Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After upgrade to 6.0, Add-ons Manager does not load any data. It says it's loading, but nothing ever happens.

  • 7 replies
  • 23 have this problem
  • 15 views
  • Last reply by ccom47

more options

After upgrading to Firefox 6.0, when I click on Tools and then Add-ons, the Add-ons Manager launches and says it's loading. But nothing ever gets loaded.

After upgrading to Firefox 6.0, when I click on Tools and then Add-ons, the Add-ons Manager launches and says it's loading. But nothing ever gets loaded.

Chosen solution

It could just simply be due to addons.mozilla.org getting hammered at times as people are checking for extension updates as Firefox 6.0/3.6.20, Thunderbird 6.0 and SeaMonkey 2.3 was released Tuesday today.

Just select Extensions or Plugins or Appearance (themes) and it will open to that panel next time instead of Get Add-ons panel.

Read this answer in context 👍 0

All Replies (7)

more options

Troubleshooting extensions and themes

Remove/Uninstall Multiple Java Console extensions

Troubleshooting plugins

Check and tell if its working.

more options

Thanks for the suggestions. When you click on Tools and then Add-ons, theAdd-on Manager launches, and by default "Get Add Ons" is selected. Although I was not getting any response other than "Loading", if I then click on Extensions or Appearance or Plugins, I was getting a proper response from those three. After doing that and closing out Add-ons Manager and then relaunching it, my original problem disappeared. Now everything works fine. I tested it multiple times and is still OK. Can't explain it but OK for now. Maybe the Get Add-ons portion of the Web site was down at the times I was testing it? I'll keep a watch on it. Thanks for your speedy reply.

more options

FF6 did the same thing to me, but worse. It also crashed my computer once and turned off my sound system. Even if FF6 had worked, several of my add-ons, including two important security ones, would not have been compatible, suggesting to me that FF6 came out too soon. I uninstalled FF6 and installed FF5.01, and now FF and my computer work fine. I will await a real fix to FF6 before trying it again, or, if there is a serious security issue being addressed by FF6, I'll switch to Chrome.

more options

To help other users find solutions, please return to this Thread and Sign-in to the forum with your Username and Password:

click on "Solved It" Next to the reply ABOVE that BEST solved your question

DO NOT click "Solved It" next to this reply

more options

Note to mha007. I had stated that the Add-ons Manager just started working normally in a prior posting so there was no specific solution recommended to me that resolved the issue, which is why I didn't click on "Solved It". I appreciate your willingness to help out.

more options

Chosen Solution

It could just simply be due to addons.mozilla.org getting hammered at times as people are checking for extension updates as Firefox 6.0/3.6.20, Thunderbird 6.0 and SeaMonkey 2.3 was released Tuesday today.

Just select Extensions or Plugins or Appearance (themes) and it will open to that panel next time instead of Get Add-ons panel.

Modified by James

more options

James, I think you are correct. It acted like it was waiting for a response from the server which never came. So there really wasn't any problem or defect with 6.0. Thanks for your comments.