X
Tap here to go to the mobile version of the site.

Support Forum

Why are the soft shadows on photos on my website now hard shadows?

Posted

My website photos look good on Safari but on Firefox they look horrible with a hard black outline and shadow. I have this problem with both of my websites. I have a 17" Mac Pro Laptop, system MAC OSX, ver 10.6.8

The url below has more photos than this which only has a shadow on this page http://stanstoj.com/About_Me.html

My website photos look good on Safari but on Firefox they look horrible with a hard black outline and shadow. I have this problem with both of my websites. I have a 17" Mac Pro Laptop, system MAC OSX, ver 10.6.8 The url below has more photos than this which only has a shadow on this page http://stanstoj.com/About_Me.html

Additional System Details

Sites Affected

http://web.me.com/stanstoj/landscapes/Home.html

Installed Plug-ins

  • iPhoto6
  • Office Live Update v1.0
  • RealPlayer Plugin
  • 4.0.51204.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.3 r181

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Application Basics
Name
Firefox
Version
5.0.1
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Web Developer
1.1.9
true
{c45c406e-ab73-11d8-be73-000a95be3b12}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
60
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110707182747
browser.startup.homepage_override.mstone
rv:5.0.1
extensions.lastAppVersion
5.0.1
font.size.variable.x-western
14
network.cookie.cookieBehavior
1
network.cookie.prefsMigrated
true
network.image.imageBehavior
0
places.database.lastMaintenance
1311593996
places.history.expiration.transient_current_max_pages
64424
places.last_vacuum
1299676467
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
true
print.print_bgimages
true
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_page_delay
50
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
20
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
12
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.disable_button.openCertManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
0x21900,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
ATI Technologies Inc. -- ATI Radeon X1600 OpenGL Engine -- 2.0 ATI-1.6.36
GPU Accelerated Windows
0/1

Hasan 469 solutions 5600 answers

-> click Firefox button and click Exit

Start Firefox in Safe Mode by Holding down the Option key while starting your Mozilla application.

As an alternate method, go to Utilities (in the Applications folder) and open Terminal, then run:

    /Applications/Firefox.app/Contents/MacOS/firefox-bin -safe-mode 

Firefox will open up with just basic Firefox. Now do this:

-> Update ALL your Firefox Plug-ins https://www.mozilla.com/en-US/plugincheck/

-> Right-click on Tab Strip and unselect All Unwanted/Incompatible Toolbars

-> click Firefox button, go to History Menu and click Clear Recent History... -> Time range to clear: select "EVERYTHING" -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache -> click Clear Now

-> click Firefox button, click Options -> go to General section -> in Startup section click Reset to Default button

-> go to Content section -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Privacy section -> History section -> Firefox will: select "Remember History"

-> go to Security section -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries

-> go to Advanced section -> Network -> Offline Storage (Cache): click Clear Now button

-> Click OK on Options window

-> click the Firefox button, click Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious/Incompatible Extensions (Add-ons)

-> click the Firefox button, click Add-ons -> Appearance section -> REMOVE All Unwanted/Suspicious/Incompatible Themes (Persona)

-> Restart Firefox

You can enable your Known & Trustworthy Add-ons and Themes later. Check and tell if its working.

-> click '''Firefox''' button and click '''Exit''' Start Firefox in Safe Mode by Holding down the '''Option''' key while starting your Mozilla application. As an alternate method, go to Utilities (in the Applications folder) and open Terminal, then run: /Applications/Firefox.app/Contents/MacOS/firefox-bin -safe-mode Firefox will open up with just basic Firefox. Now do this: -> Update ALL your Firefox Plug-ins https://www.mozilla.com/en-US/plugincheck/ -> Right-click on '''Tab Strip''' and unselect All Unwanted/Incompatible Toolbars -> click '''Firefox''' button, go to '''History Menu''' and click '''Clear Recent History...''' -> '''Time range to clear: select "EVERYTHING"''' -> click Details (small arrow) button -> place Checkmarks on '''Cookies, Cache''' -> click '''Clear Now''' -> click Firefox button, click Options -> go to General section -> in '''Startup''' section click '''Reset to Default''' button -> go to Content section -> place Checkmarks on: 1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript -> go to Privacy section -> History section -> '''Firefox will: select "Remember History"''' -> go to Security section -> place Checkmarks on: 1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries -> go to Advanced section -> Network -> Offline Storage (Cache): click '''Clear Now''' button -> Click OK on Options window -> click the Firefox button, click Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious/Incompatible Extensions (Add-ons) -> click the Firefox button, click Add-ons -> Appearance section -> REMOVE All Unwanted/Suspicious/Incompatible Themes (Persona) -> Restart Firefox You can enable your Known & Trustworthy Add-ons and Themes later. Check and tell if its working.

Question owner

I work on a Mac so locating some buttons is slightly different. I do think I followed all your steps, yet I still have hard drop shadows on my photos. ;-(

I work on a Mac so locating some buttons is slightly different. I do think I followed all your steps, yet I still have hard drop shadows on my photos. ;-(
Hasan 469 solutions 5600 answers

are you using any Photos related add-on ?? you might need to configure it

are you using any Photos related add-on ?? you might need to configure it

Question owner

No Photo add-ons. All plug-ins are disabled.

No Photo add-ons. All plug-ins are disabled.
Hasan 469 solutions 5600 answers

and what about any Photos Extensions (add-ons) ???

and what about any Photos Extensions (add-ons) ???

Question owner

No Extensions.

No Extensions.
Hasan 469 solutions 5600 answers
That is a bug. See this post https://support.mozilla.com/en-US/questions/841539
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158559 answers

That is unfortunately a bug (Bug 662898) that slipped into Firefox 5 and that will be fixed in Firefox 6, due to be released in August.


That is unfortunately a bug (Bug 662898) that slipped into Firefox 5 and that will be fixed in Firefox 6, due to be released in August. ---- *http://forums.mozillazine.org/viewtopic.php?f=25&t=2240429 *[/questions/843162]

Question owner

At least I now know I'm not going crazy! Thanks for the info. Any bug sprays available until Firefox 6 comes out?

At least I now know I'm not going crazy! Thanks for the info. Any bug sprays available until Firefox 6 comes out?

Modified by stanray

cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158559 answers

You're welcome

You're welcome