X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Where can I Download older versions?

Posted

Where can I download older versions of Firefox?

Additional System Details

Installed Plug-ins

  • WindizUpdate for Firefox, Mozilla, Opera and Netscape; version 2.0.2007.0309. For details, visit windizupdate.com
  • 6.0.12.69
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 1.9.0009.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Winamp Application Detector
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Google Update
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • iLok Client Helper Plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60310.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Ricmacas 5 solutions 73 answers

Older versions of Firefox can be downloaded from Mozilla FTP here. No support or security updates are offered to some of these versions. Proceed with caution.

Helper7677 165 solutions 1653 answers

The only currently supported versions are 3.6.18 and 5.0. Firefox 5.0 was an upgrade from Firefox 4.0.1 and includes security updates that Firefox 4.0.1 does not include. All other versions contain security issues and should not, for your own protection, be used.

You can get Firefox from:




You need to update the following. The Plugin version(s) shown below was/were submitted with your question and is/are out of date. You should update to avoid known security issues with the version(s) you have installed. Click on "More system info..." to the right of your question to see what was included with your question.

  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  1. Check your plugin versions on either of the following links':
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
    • After the installation, start Firefox and check your version again.
  4. Update the Java plugin to the latest version.

Modified by Helper7677

ClayFerguson 0 solutions 1 answers

Thank you RICMACAS! This is what I needed (the link you posted)

http://ftp.mozilla.org/pub/firefox/releases/