Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

need to down load the latest 3.6, where can I find it? 4.0 will not work with my zone alarm

  • 2 replies
  • 11 have this problem
  • 1 view
  • Last reply by yvliu09

more options

The laptop was shut down while firefox was updating on its own. Now it is broken with "bad image" message. I need to down load the latest 3.6 version, but I can only find 4.0. I can not use 4.0 because my current verison of zonealarm is not compatible. Please advise.

Chosen solution

All Replies (2)

more options

Chosen Solution

more options

Thanks, Got the image I need, and solved the problem.