X
Tap here to go to the mobile version of the site.

Support Forum

How to stop FF checking compatibility of add-ons every time it starts.

Posted

Since upgrading to 4.0.1, FF checks compatibility of add-ons every time it starts. How to stop this?

Since upgrading to 4.0.1, FF checks compatibility of add-ons every time it starts. How to stop this?

Additional System Details

This happened

Every time Firefox opened

This started when...

after upgrading to 4.0.1

Installed Plug-ins

  • DjVu browser plugin
  • Shockwave Flash 10.2 r159
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
13075 solutions 119707 answers
Try: * http://kb.mozillazine.org/Preferences_not_saved

Question owner

Unfortunately this doesn't solve the problem.

Unfortunately this doesn't solve the problem.
cor-el
  • Top 10 Contributor
  • Moderator
13075 solutions 119707 answers

Did you delete prefs.js in the Firefox Profile Folder?

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

This can also be a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (extensions.sqlite, extensions.rdf, extensions.cache, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. New files will be created when required.

See "Corrupt extension files": http://kb.mozillazine.org/Unable_to_install_themes_or_extensions

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the "Find Updates" button (Firefox 4: click the Tools button at the left side of the Search Bar) to do a compatibility check.

Did you delete prefs.js in the [http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox Profile Folder]? * Help > Troubleshooting Information > Profile Directory: Open Containing Folder This can also be a problem with the file(s) that store the extensions registry. Delete the files extensions.* (extensions.sqlite, extensions.rdf, extensions.cache, extensions.ini) and compatibility.ini in the Firefox [[Profiles|profile folder]] to reset the extensions registry. New files will be created when required. See "Corrupt extension files": http://kb.mozillazine.org/Unable_to_install_themes_or_extensions If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the "Find Updates" button (Firefox 4: click the Tools button at the left side of the Search Bar) to do a compatibility check.
MisterRon 0 solutions 1 answers

Nothing works! I have Firefox constantly checking the compatibility of extensions (add ons) , and a window always opens saying it's been updated. There is no "prefs.js" in my profile folder. The only alternative I seem to have is to get rid of Firefox and use another browser. This has been a terrible experience with Firefox for the past 2 updates of the browser. It just seems to get worse with every upgrade! As much as I hate to say it, I guess it's . . Hello Chrome!

Nothing works! I have Firefox constantly checking the compatibility of extensions (add ons) , and a window always opens saying it's been updated. There is no "prefs.js" in my profile folder. The only alternative I seem to have is to get rid of Firefox and use another browser. This has been a terrible experience with Firefox for the past 2 updates of the browser. It just seems to get worse with every upgrade! As much as I hate to say it, I guess it's . . Hello Chrome!
cor-el
  • Top 10 Contributor
  • Moderator
13075 solutions 119707 answers

Look that you didn't find the Firefox Profile Folder

Look that you didn't find the Firefox Profile Folder * http://kb.mozillazine.org/Profile_folder_-_Firefox *Help > Troubleshooting Information > Profile Directory: Open Containing Folder * https://support.mozilla.com/kb/Using+the+Troubleshooting+Information+page

Question owner

I solved the problem by brute force. When FF5 became available, I saved my bookmarks as html, completely uninstalled FF4 (incl. profiles, extensions, etc.), then installed FF5, imported the saved bookmarks, and installed the most needed extensions (as far as they were compatible with FF5).

I solved the problem by brute force. When FF5 became available, I saved my bookmarks as html, completely uninstalled FF4 (incl. profiles, extensions, etc.), then installed FF5, imported the saved bookmarks, and installed the most needed extensions (as far as they were compatible with FF5).

Modified by koantum

Tyler7243 0 solutions 1 answers

1. Firefox orange button>help>Troubleshooting Information

2. Under Application Basics, click Open Containing Folder

3. there will be prefs.js, user.js and sessionstore.js

4. Delete all 3 files

5. restart and done.

1. Firefox orange button>help>Troubleshooting Information 2. Under Application Basics, click Open Containing Folder 3. there will be prefs.js, user.js and sessionstore.js 4. Delete all 3 files 5. restart and done.