X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Sites say cookies not enabled, but they are!

Posted

My privacy setting are 'accept third party cookies' and I haven't changed this at all. However, since installing firefox more and more sites are telling me cookies are not enabled - but they are. This happens over time to EVERY firefox installation I have, no matter what machine its' on and no matter what OS - it starts fine gradually gets worse and worse rejecting more and more cookies! WHY!

Additional System Details

Installed Plug-ins

  • getplusplusadobe16244
  • Yahoo! activeX Plug-in Bridge
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • 1.9.0042.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • 12.0.1.633
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • CouponNetwork Coupon Activator
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.51204.0
  • Office Live Update v1.5
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • BlackBerry WebSL Browser Plug-In
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

dynamite 60 solutions 382 answers

Check if the instructions in these articles help: Websites say cookies are blocked and Websites say cookies are disabled.

Question owner

I'd already got most of those settings - but I'll keen an eye on when it next happesn and try the rest of the fix. Thanks!

dynamite 60 solutions 382 answers

A couple of more things: You should verify that cookies are permitted for the website. To do that, open the website and check cookie permissions in Tools > Page Info > Permissions.

Also, in case you are using a firewall, check if it is not blocking the cookies.

Question owner

Yup, done both those. SEEMS to be behaving now, but I'll not hold my breath. Thanks.

Question owner

Now its back again - Facebook is the latest 'victim' and say cookies not enabled on your browser - did all the fixes and still won't let me in.

dynamite 60 solutions 382 answers

What does "Tools > Page Info > Permissions" show for Facebook?

Helpful Reply

Well thats' interesting - even though cookies were enabled in the options menu - on this page they were blocked, but I was still having the same problem after allowing them! It only made a difference when I selected the allow for session option !