X
Tap here to go to the mobile version of the site.

Support Forum

Why does firefox want to use different fonts on mounted hard drives

Posted

On Mac OS 10.6.5 using Firefox 3.6.12 upon opening Firefox, I get a dialog box that says "Firefox want to use the font "TremorlTC TT" on the volume "USB BU".

This happens for both of my external hard drives. It gives me the options: Show in Finder Don't Allow or Allow. I have tried all 3 and neither solves the problem.

On Mac OS 10.6.5 using Firefox 3.6.12 upon opening Firefox, I get a dialog box that says "Firefox want to use the font "TremorlTC TT" on the volume "USB BU". This happens for both of my external hard drives. It gives me the options: Show in Finder Don't Allow or Allow. I have tried all 3 and neither solves the problem.

Modified by cor-el

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • npmnqmp 071505000006
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX Web Player version 1.4.1.4
  • iPhoto6
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16789 solutions 151723 answers

Chosen Solution

See [http://www.google.com/search?hl=en&ie=UTF-8&q=cache:http://support.mozilla.com/tiki-view_forum_thread.php%3Fcomments_parentId%3D625704%26forumId%3D1 How can I stop Firefox from asking me to install fonts every time I launch?] See also [https://bugzilla.mozilla.org/show_bug.cgi?id=567552 Bug 567552] (please do not comment in bug reports)

Question owner

See image to graphically define the problem.

The forum directed me to Font Book (definitely a font problem) on Mac OS 10.6.5. I did not want to delete any fonts because that can be a recipe for disaster down the line. I opened Font Book and did the following based upon the recommendations: In preferences I changed the default install location from user to computer and I unchecked Automatic font activation. In the app I opened up user fonts and selected all. Then I dragged them and dropped them on computer fonts. While in computer fonts, from the edit menu I selected "select duplicated fonts". Then I selected resolve all duplicates (while in computer fonts). I closed Firefox and reopened and problem solved. I have yet to experience any fallout on my computer. If I do I will know where to go.Thanks to the forum for pointing me in the right direction.

See image to graphically define the problem. The forum directed me to Font Book (definitely a font problem) on Mac OS 10.6.5. I did not want to delete any fonts because that can be a recipe for disaster down the line. I opened Font Book and did the following based upon the recommendations: In preferences I changed the default install location from user to computer and I unchecked Automatic font activation. In the app I opened up user fonts and selected all. Then I dragged them and dropped them on computer fonts. While in computer fonts, from the edit menu I selected "select duplicated fonts". Then I selected resolve all duplicates (while in computer fonts). I closed Firefox and reopened and problem solved. I have yet to experience any fallout on my computer. If I do I will know where to go.Thanks to the forum for pointing me in the right direction.
cor-el
  • Top 10 Contributor
  • Moderator
16789 solutions 151723 answers

You're welcome and thanks for the explication what you did to fix it.

You're welcome and thanks for the explication what you did to fix it.
mcrowther 0 solutions 3 answers

I did the stuff suggested but when I click on the user fonts in Font book there are none listed- and the problem is still happening. I am ready to just delete Firefox and go to Safari.

I did the stuff suggested but when I click on the user fonts in Font book there are none listed- and the problem is still happening. I am ready to just delete Firefox and go to Safari.
cor-el
  • Top 10 Contributor
  • Moderator
16789 solutions 151723 answers

Helpful Reply

Move all User fonts in Font Book to Computer fonts:

  1. Launch Font Book (/Applications/Utilities/)
  2. Open Font Book > Preferences
  3. Deselect: "Automatic Font Activation"
  4. Set the "Default Install Location" for fonts to Computer
  5. Select all User fonts.
  6. Move the selected User fonts to Computer fonts
  7. Remove all duplicate fonts in Computer fonts
Move all User fonts in Font Book to Computer fonts: # Launch Font Book (/Applications/Utilities/) # Open Font Book > Preferences # Deselect: "Automatic Font Activation" # Set the "Default Install Location" for fonts to Computer # Select all User fonts. # Move the selected User fonts to Computer fonts # Remove all duplicate fonts in Computer fonts
Macmaniac 0 solutions 2 answers

Move the selected User fonts to Computer fonts

Although I cannot provide a "technical" explanation, I DO NOT view this as a good solution. If all your fonts are stored in "Computer fonts" (rather than some being stored in "User fonts") why would Apple provide users with these options in Font Book?

There is a reason why one would want certain fonts stored in User fonts and not stored in Computer fonts..............this is especially pertinent when certain fonts are being used occasionally as in the case of graphic arts assignments. I believe Mozilla needs to come up with a better solution...........because the solution offered does not really solve the problem or situation.

''Move the selected User fonts to Computer fonts '' Although I cannot provide a "technical" explanation, I DO NOT view this as a good solution. If '''all''' your fonts are stored in "Computer fonts" (rather than some being stored in "User fonts") why would Apple provide users with these options in Font Book? There is a reason why one would want certain fonts stored in User fonts and '''not stored''' in Computer fonts..............this is especially pertinent when certain fonts are being used occasionally as in the case of graphic arts assignments. I believe Mozilla needs to come up with a better solution...........because the solution offered does not really solve the problem or situation.

Modified by Macmaniac