X
Tap here to go to the mobile version of the site.

Support Forum

How to remove automatic redirects on Firefox?

Posted

When I type in a website that does not exist, I am redirected to an Ad from "sendoriads.searchassist.com powered by Yahoo". This is not the case with IE? When I search for a solution to block this on my Firefox it says to go to Tools and Options to block automatic redirects. But, that option is not there?

When I type in a website that does not exist, I am redirected to an Ad from "sendoriads.searchassist.com powered by Yahoo". This is not the case with IE? When I search for a solution to block this on my Firefox it says to go to Tools and Options to block automatic redirects. But, that option is not there?

Additional System Details

This happened

Every time Firefox opened

This started when...

typing in a non-existant website

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.43.3
  • Version 1.4.2.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • np-mswmp
  • Google Update
  • Shockwave Flash 10.0 r32
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 3.0.50611.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12305 solutions 113968 answers

Do a malware check with a few malware scan programs.
You need to use all programs because each detects different malware.
Make sure that you update each program to get the latest version of the database before doing a scan.

See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked and What to do when searches take you to the wrong search website

Do a malware check with a few malware scan programs.<br /> You need to use all programs because each detects different malware.<br /> Make sure that you update each program to get the latest version of the database before doing a scan. * http://www.malwarebytes.org/mbam.php - Malwarebytes' Anti-Malware * http://www.superantispyware.com/ - SuperAntispyware * http://www.safer-networking.org/en/index.html - Spybot Search & Destroy * http://www.lavasoft.com/products/ad_aware_free.php - Ad-Aware Free * http://www.microsoft.com/windows/products/winfamily/defender/default.mspx - Windows Defender: Home Page See also "Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked and [[Searches are redirected to another site]]

Question owner

Thank you for the response.. I presently use malwarebytes and ad-aware.. But, will also try the others..

Previous versions of Firefox had an option for blocking automatic redirects but, the latest version does not?? Or at least I cannot find them in the Admin tools area where they once existed. I would like to block the automatic redirects which was once possible in the Options admin area?? Does Firefox earn revenue from these "Searchassist" Redirects?

Thank you for the response.. I presently use malwarebytes and ad-aware.. But, will also try the others.. Previous versions of Firefox had an option for blocking automatic redirects but, the latest version does not?? Or at least I cannot find them in the Admin tools area where they once existed. I would like to block the automatic redirects which was once possible in the Options admin area?? Does Firefox earn revenue from these "Searchassist" Redirects?
Sonnilion 0 solutions 1 answers

You can stop automatic redirects in Firefox with tools/options/advanced/general, beneath the "accessibility" header.

At least one ISP redirects misspelled URLs to that URL. If this is the case, on the page to which you're redirected, scroll to the bottom and look at the far right. There should be a link saying "About this site." If you click it, it will give you a link to a page on your ISP's site that will allow you to opt out of having your browser hijacked.

You can stop automatic redirects in Firefox with tools/options/advanced/general, beneath the "accessibility" header. At least one ISP redirects misspelled URLs to that URL. If this is the case, on the page to which you're redirected, scroll to the bottom and look at the far right. There should be a link saying "About this site." If you click it, it will give you a link to a page on your ISP's site that will allow you to opt out of having your browser hijacked.