Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

cannot disable save history, i change to never save and it still saves it

  • 2 replies
  • 2 have this problem
  • Last reply by Cheng Wang

more options

i am trying to change my history and my password not to save everytime we go on firefox.. and it does not work it still save my web sites password, i have uninstall and reinstalled twice, ran spyware, malware, virus cleared manually still cannot get history to delete everytime i close firefox. could you help..


All Replies (2)

more options

You have to clear your existing passwords. The setting only applies to new websites. Tools > Options > Security > Saved Passwords > Remove All

more options

For History, do Tools > Options > Privacy and select Firefox will Never remember history