X
Tap here to go to the mobile version of the site.

Support Forum

npapi or webkit plugin are not working in firefox

Posted

I have a Webkit plugin and NPAPI plugin. Both work fine in Safari but just would not work in Firefox (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3) .

about:plugins shows it as installed but when I try to access it from html page none of the entry points in a code are being called.(None of trace statement are being hit) I think Firefox has problem loading those plugins.

I have similar NPAPI plugin working fine in Windows environment on all browsers, but MAC is giving me this problem.

Does anyone has any ideas of what could be the problem?


I even took a BASICPLUGIN sample for MAC and it has the same problem. Anyb


This happened

Every time Firefox opened

I have a Webkit plugin and NPAPI plugin. Both work fine in Safari but just would not work in Firefox (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3) . about:plugins shows it as installed but when I try to access it from html page none of the entry points in a code are being called.(None of trace statement are being hit) I think Firefox has problem loading those plugins. I have similar NPAPI plugin working fine in Windows environment on all browsers, but MAC is giving me this problem. Does anyone has any ideas of what could be the problem? I even took a BASICPLUGIN sample for MAC and it has the same problem. Anyb == This happened == Every time Firefox opened

Additional System Details

Installed Plug-ins

  • -Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Amoeba Download Manager plugin - NPAPI version
  • LogMeIn remote control components
  • Java Plug-In 2 for NPAPI Browsers
  • 3.0.50106.0
  • Shockwave Flash 10.0 r42
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

AnonymousUser 405 solutions 14878 answers

Getting the same experience here.

Getting the same experience here.
AnonymousUser 405 solutions 14878 answers

Christofer,

I solved my problem after not getting any responses..... Turns out that some of my xcode compilation switches had to be changed, send me your minimal code that I can compile and i will help you finding it......My NSAPI plugin works just great with all mac browsers....in fact it is the same code excatly as i have for windows, just had to rename some files from .cpp to .m so that I could yuse some cocoa objects....

Mark

Christofer, I solved my problem after not getting any responses..... Turns out that some of my xcode compilation switches had to be changed, send me your minimal code that I can compile and i will help you finding it......My NSAPI plugin works just great with all mac browsers....in fact it is the same code excatly as i have for windows, just had to rename some files from .cpp to .m so that I could yuse some cocoa objects.... Mark
Tazman5307 0 solutions 1 answers

Hello!

Same issue here sir. This is on a MAC and Firefox as well.

Please help if you can sir!

Tony D

Hello! Same issue here sir. This is on a MAC and Firefox as well. Please help if you can sir! Tony D