X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Address bar is disobeying keyword.url

Posted

I have keyword.URL set to http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&btnI=I'm%20Feeling%20Lucky&q=

However, when I type 'foo' into my address bar, it tries to take me to http://foo/ instead of executing a google search for foo and taking me to the first hit, which is what I was expecting. I end up seeing a message from my ISP that the site does not exist. Anyone know how to fix this? Google only seems to turn up advice on changing keyword.url, with nothing on forcing firefox to obey keyword.url.

Additional System Details

Installed Plug-ins

Adobe Acrobat 9.3.2.163, Google Talk Plugin 1.1.2.0, Google Update 1.2.183.23, Java(TM) Platform SE 6 U17 6.0.170.4, Microsoft DRM 9.0.0.4503 (listed twice in my plugins list), Mozilla Default Plug-in 1.0.0.15, QuickTime Plug-in 7.6.5 7.6.5.0, RealPlayer Version Plugin 6.0.12.69, RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit) 6.0.12.69, Shockwave Flash 10.0.45.2, Silverlight Plug-In 3.0.50106.0, Windows Genuine Advantage 1.7.69.3, Windows Media Player Plug-in Dynamic Link Library 3.0.2.629

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.0.11 NET_mmhpset ( .NET CLR 3.5.30729)

More Information

Adblock Plus 1.2, CHM Reader 0.2.3, FireBug 1.5.4, Java Console 6.0.16, Microsoft .NET Framework Assistant 1.2.1, NoScript 1.9.9.74, PDF Download 3.0.0.1, Tab Mix Plus 0.3.8.2, Torbutton 1.2.5

Question owner

Ensure keyword.enabled is true. More importantly, if you want it to trigger when you type a single word instead of multiple words, you need to set browser.fixup.alternate.enabled to false

Question owner

Thank you for the advice!

keyword.enabled was and remains true (I didn't know it needed checking, so thanks).

browser.fixup.alternate.enabled was true; I set it to false, but am getting identical behaviour.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

http://en.wikipedia.org/wiki/DNS_hijacking http://forums.mozillazine.org/viewtopic.php?f=38&t=1874045 - My ISP is by-passing Firefox's Location bar search ..... You may have an ISP that automatically redirects you to a search page if a DNS look up fails. That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search. In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.

saadrehman 0 solutions 1 answers

Helpful Reply

@cor-el I don't think that's the problem here. Because this functionality seems to be working fine when I enter multiple keywords in the location bar. (Not calling it 'awesome' bar unless I get this thing fixed :p)

-Saad