Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

web pages in take ages to load in firefox in ubuntu lucid

  • 3 replies
  • 1 has this problem
  • 37 views
  • Last reply by Moses

more options

i have both ubuntu and win xp in xp firefox runs fine but in ubuntu(lucid) although i ave a good broadband speed of abt 1Mbps and the usual download speed goes to abt 200 to 250 Kbps the web pages take ages to load about 2 min for yahoo home page to load i have updated with the update manager

This happened

Every time Firefox opened

All Replies (3)

more options

Try a clean install of Firefox on your Linux machine.

  1. Close Firefox completely. (File->Exit on Windows/Linux, Firefox->Quit on Mac)
  2. Rename the Firefox installation folder or move it elsewhere.
  • Linux: The install location varies based on distribution and installation method. Linux distributions usually don't put Firefox in its own folder, so this method can't be used.

3. [www.getfirefox.com Download Firefox] again and install it

Installing Firefox in Linux

If this fixes the problem, you can optionally check the old install folder for global extensions, components, or corrupt/locked files.

more options

can i use synaptech to un-install i dunno anything about linux terminals

more options

Try to disable IPv6 in Firefox, see http://kb.mozillazine.org/Error_loading_websites#IPv6