Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Downloads Update

  • 1 reply
  • 1 has this problem
  • 17 views
  • Last reply by FredMcD

more options

I used to have prompt every time I would download something... I would like it back, how can I do this? I've already tried to ask Firefox to always ask me where I would like to open my download but when it does I removes the name of my PDF and acts like they are textedit files and now when I download JPGS it wont even give me an option to choose to have Firefox ask me for the file type "JPG". How can I get everything back to the way it used to be before the update version 98.0?

I used to have prompt every time I would download something... I would like it back, how can I do this? I've already tried to ask Firefox to always ask me where I would like to open my download but when it does I removes the name of my PDF and acts like they are textedit files and now when I download JPGS it wont even give me an option to choose to have Firefox ask me for the file type "JPG". How can I get everything back to the way it used to be before the update version 98.0?
Attached screenshots

All Replies (1)

more options

https://www.mozilla.org/en-US/firefox/98.0/releasenotes/ Firefox has a new optimized download flow . . . .

https://support.mozilla.org/en-US/kb/manage-downloads-preferences-using-downloads-menu Changes to how file downloads are handled in Firefox version 98

  • Firefox no longer asks what to do for each file by default
  • Downloads panel automatically opens
  • Downloaded files are saved to disk
  • Set a default app to open a file type
  • "Always Open Similar Files" option from the Downloads panel
  • Frequently asked questions


You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.