Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Replacing Firefox 78 for OS 10 El Capitan

  • 3 replies
  • 1 has this problem
  • 1682 views
  • Last reply by James

more options

Hello, I've followed Firefox's invitation to install and update the browser on my Mac. Unfortunately the new version is not compatible with OS 10 El Capitan, my operating system, so now I can't use Firefox at all. How I do get the old version back?

Thank you, Lars

Hello, I've followed Firefox's invitation to install and update the browser on my Mac. Unfortunately the new version is not compatible with OS 10 El Capitan, my operating system, so now I can't use Firefox at all. How I do get the old version back? Thank you, Lars

Chosen solution

Hi Lars, the last release of the Firefox 78 Extended Support Release series for Mac can be found here:

http://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/

Click into the "locale" you prefer -- usually it's the one that was in the address bar while you were on this site, for example,

https://support.mozilla.org/en-US/questions/1363934

More info:

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi Lars, the last release of the Firefox 78 Extended Support Release series for Mac can be found here:

http://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/

Click into the "locale" you prefer -- usually it's the one that was in the address bar while you were on this site, for example,

https://support.mozilla.org/en-US/questions/1363934

More info:

more options

Hi - it's good of you to take the time to reply. I've reinstalled the right version and it's even kept my bookmarks and saved log-ins. Good news. Thanks so much, Lars

more options

/moved thread from Firefox for iOS (for iPhone/iPad) to Firefox (desktop) section.

Firefox 79.0 and later (including Fx 95.0 and Fx 91.0 ESR) has required macOS 10.12 (ten.twelve) at minimum to run.

Modified by James