Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't stream video

  • 6 replies
  • 1 has this problem
  • 36 views
  • Last reply by ShenLoong99

more options

Suddenly videos won't play on one particular news website (others are fine), I've tried every possible solution I could find on the net (clear cache, uncheck hardware accelleration, allow audio & video, fiddled with permissions and protection,...). MacBook Pro (Retina, 13-inch, Mid 2014), recently updated to Big Sur 11.4 (hoping the problem would go away, issue already there with Catalina), 2,6 GHz Dual-Core Intel Core i5, video Intel Iris 1536 MB. Please, can anyone help?

All Replies (6)

more options

Still having same problem, sometimes videos stream but then it just stops. Why???

Helpful?

more options

You can try these below: 1. Update Mozilla Firefox Browser updates are known to improve speed and protect against viruses. Plus, they can also fix bugs and software conflicts on your system. So if Firefox is not playing videos, try to troubleshoot by updating Firefox. Steps to update Firefox: a. Open Firefox and click on the Firefox menu (three bars) button at the top-right corner. b. Select Help > About Firefox. c. About Mozilla Firefox window opens. Firefox automatically checks for updates and downloads them. d. When the download finishes, click on Restart to update Firefox and follow the on-screen instructions.

2. Disable Add-ons You may be using add-ons like extensions, themes, or plugins to customize your Mozilla Firefox browser. However, these add-ons can prevent website videos from loading in Firefox. Try to fix the video issue by disabling your Firefox add-ons – extensions, themes, and plugins. Steps to disable Firefox extensions: a. Open the Firefox menu. b. Select Add-ons from the list. c. Click on Extensions on the left. d. Toggle off each Add-on to disable. e. Restart Firefox. Steps to disable Firefox themes: a. Click on the Firefox menu icon. b. Click Add-ons. c. Select Themes. d. Under enabled themes list, disable each theme. Note: Do not disable Default theme. Steps to disable Firefox plugins: a. Click on the Firefox menu. b. Click on Add-ons and select Plugins on the left-side bar. c. Scroll through the list of plugins. d. Click on the 3-dots and select Never Activate from the drop-down.

3. Enable Autoplay in Firefox By default, Mozilla Firefox blocks website videos with sound to play automatically. You will have to enable ‘Autoplay’ to play online videos in Firefox. Apply any of the below ways to enable ‘Autoplay’ when videos not working in Firefox: Way 1: Allow Autoplay using Firefox Options a. Open Firefox menu. b. Select Options and click on Privacy and Security in the left. c. Scroll down to Permissions. d. Find Autoplay and click Settings. e. Across Default for all websites, select Allow Audio and Video from the drop-down. f. Next, click Save Changes. The settings will apply to all the websites you open in the Firefox browser. Way 2: Allow Autopay from website settings in Firefox: a. Open the website URL in the Firefox browser. b. Click on the lock icon in the address bar. c. Open the Site Information drop-down. d. Under Permissions,click on Autoplay drop-down.

4. Refresh your Firefox If none of the above methods work, refresh your browser. Steps to refresh Firefox: a. Open the Firefox menu. b. Click Help > troubleshooting information. c. Click Refresh Firefox.

Helpful?

more options

I appreciate your help, yithuettsk29. I've tried all that. I've even emptied and reformatted my MacBook Pro, and upgraded to Big Sur. No result...

Helpful?

more options

What I thought of is that it could be due to the Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: https://support.mozilla.org/en-US/kb/what-happened-tracking-protection?redirectslug=tracking-protection&redirectlocale=en-US

Could you try disabling the graphics hardware acceleration in Firefox again? Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below: 1. Click the menu button (top right corner) and select Options (Windows) or Preferences (Mac, Linux). 2. Select the Advanced panel and the General tab. 3. Uncheck Use hardware acceleration when available. 4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above: 1. Click the menu button (top right corner) and select Options (Windows) or Preferences (Mac, Linux). 2. Select the General panel. 3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed. 4. Uncheck Use hardware acceleration when available. 5. Close Firefox completely and then restart Firefox to see if the problem persists.

Source: https://support.mozilla.org/en-US/questions/1214018

Helpful?

more options

Thanks ShenLoong99,

I'm afraid this hasn't solved the issue. I'm getting so frustrated with this.

Helpful?

more options

Could you send me the link of the news website so that I can replicate the error? Did the website shows any error message or error code?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.