Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Nothing Loading Within Firefox Application

  • 4 replies
  • 1 has this problem
  • Last reply by AliceWyman

more options

When opening Firefox, a window opens with menus and toolbars visible, but nothing loads or opens up when navigating the application. No websites are loading, no menus are opening such as options or add-ons, and not even the mozilla landing page is loading. I have tried doing a "Refresh". I have tried doing a clean reinstall. I have run virus scans to see if malware was preventing it from opening websites. I am having no issues with other browsers, just Mozilla Firefox. I am unsure what to do if even a Firefox reinstall is not working. The application wont even let me enable/disable add ons to see if that may be causing the problem.

Attached screenshots

Chosen solution

Note that this is likely caused by missing this specific DLL: VCRUNTIME140_1.dll

Read this answer in context 👍 0

All Replies (4)

more options

What's your computer system and Firefox version?

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

I fixed the problem I was having by uninstalling all my Microsoft Visual C++ Redistributables excluding 2015-2019 x64. That being said, I don't recommend this solution for everyone as it may disrupt the functionality of other applications that rely on them. For example, I already had to reinstall Microsoft Visual C++ 2015-2019 Redistributable (x86) for a few of my applications to run

Modified by csioufi3

more options

Chosen Solution

Note that this is likely caused by missing this specific DLL: VCRUNTIME140_1.dll

more options

(For the record) Related bug: Bug 1624546 Include vcruntime140_1.dll for VS2019 16.5 x64 from the redist directory in the package (quote)

Robins New to Bugzilla Comment 17 • 2020-12-15 05:26 EST Not sure if this helps anyone else but this resolved my issue... (I was stuck on this issue for a few months)

Merely reinstalling the Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 for my laptop architecture resolved the issue for me.

For anyone else having this problem, Visual Studio 2015, 2017 and 2019 installer files are available here (on 64-bit systems, install both): x86: vc_redist.x86.exe x64: vc_redist.x64.exe