Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Vertical bar always displaying wherever i click on Firefox

more options

Do someone know how to fix this issue? Maybe with an update or reinstalling the browser.

Attached screenshots

Chosen solution

Could you check to make sure the "caret browsing" feature is not enabled? You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the tiny search box at the top of the page, type cursor and Firefox should filter to the "Browsing" section. If the box is checked for "Always use the cursor keys to navigate within pages" then uncheck that box.

If you changed that, does it make any difference?


Edit:

There also is another way to manage this feature that is a little more under the covers:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste caret and pause while the list is filtered

(3) If the accessibility.browsewithcaret preference is bolded and has a value of true, double-click it to restore the default value of false

(4) If you do not want the F7 key to switch this feature on and off, double-click the accessibility.browsewithcaret_shortcut.enabled preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Hope that helps!

P.S. If you quote a URL like an image address in a reply, your post may be delayed while it is checked for spam.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Could you check to make sure the "caret browsing" feature is not enabled? You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the tiny search box at the top of the page, type cursor and Firefox should filter to the "Browsing" section. If the box is checked for "Always use the cursor keys to navigate within pages" then uncheck that box.

If you changed that, does it make any difference?


Edit:

There also is another way to manage this feature that is a little more under the covers:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste caret and pause while the list is filtered

(3) If the accessibility.browsewithcaret preference is bolded and has a value of true, double-click it to restore the default value of false

(4) If you do not want the F7 key to switch this feature on and off, double-click the accessibility.browsewithcaret_shortcut.enabled preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Hope that helps!

P.S. If you quote a URL like an image address in a reply, your post may be delayed while it is checked for spam.

Modified by jscher2000

Helpful?

more options

Thank you very much, it was enabled the "Always use the cursor to navigate withing pages" option, I disabled it and now everything looks fixed.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.