Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Both receiving and sending messages work intermittently

  • 22 replies
  • 1 has this problem
  • 87 views
  • Last reply by doniel

more options

For background on my mail server setup, please see https://support.mozilla.org/en-US/questions/1242115. I've left the outgoing server setup as Yahoo simply so that I don't have to change settings every time I visit the U.S. and when I return home again.

As of a couple of days ago, clicking on Get Messages frequently results in an error message saying that the connection to the pop server timed out, and clicking on Send often gets a similar message (though of course referring to the smtp server). I haven't changed any settings since implementing sfhowes' instructions in the thread mentioned above. I have zero connection problems in Firefox.

Chosen solution

https://www.partner.co.il/u/guide_email_setting_outlook_2013

For POP accounts, the incoming server is pop.partner.net.il on port 110, connection security = none, authentication = password, transmitted insecurely, User Name = email address.

Outgoing server: smtp.partner.net.il on port 25, connection security = none, authentication = password, transmitted insecurely, User Name = email address.

Read this answer in context 👍 0

All Replies (20)

more options

I forgot to write that when I go to Yahoo Mail and send messages directly from my Yahoo account, they're immediately sent out. The problem only crops up when I send via TB through Yahoo's outgoing server. That's besides, as I wrote above, having trouble receiving messages from my ISP's pop server. (When I return to my computer after having been away for some time, I do find messages waiting for me.)

Helpful?

more options

Update: I'm still receiving here and there, but I can't send at all now.

I also forgot to write that I tried reinstalling, but I wasn't optimistic, since I had to first save my profile and then restore it after reinstalling. Would it accomplish anything if I wrote down my settings and saved my pop mail folder, allowing me to do a reinstall without restoring my profile?

Helpful?

more options

Yahoo now requires OAuth2 authentication, so you should have imap.mail.yahoo.com on 993 or pop.mail.yahoo.com on 995, smtp.mail.yahoo.com on 465; SSL/TLS, OAuth2 authentication, User Name = email address. Change the authentication on incoming and outgoing to OAuth2 if it's currently 'normal password', check that cookies are allowed in TB Options/Privacy & Security, remove the passwords from Privacy & Security/Passwords/Saved Passwords, then restart TB and enter the account password in the browser window when prompted to complete the OAuth2 authentication.

Helpful?

more options

Thank you, sfhowes. To remind you, I'm only using Yahoo for outgoing. I'm still using my ISP for incoming. Since I found what you wrote a little confusing, would you mind rewriting it, bearing in mind that your instructions should focus only on the smtp server?

Thank you so much for your help.

Helpful?

more options

Tools/Account Settings, Outgoing Server (SMTP) at the bottom of the left pane, Edit the Yahoo smtp server so the authentication method is OAuth2. Do the other steps to allow cookies and remove the Yahoo password.

Helpful?

more options

Everything was already set as should be. I'm up to the step of removing passwords. I see that there's one for oauth://login.yahoo.com. Do I want to remove that, besides the multiple other entries for Yahoo?

Helpful?

more options

I removed all the other Yahoo passwords and I still couldn't send. I then removed the password for the oauth entry. I still can't send.

Helpful?

more options

Menu app icon > Help > Troubleshooting Information Under Application Basics' section locate - Profile Folder and click on 'Open Folder' A new window opens showing the contents of your 'profile name' folder.

Close Thunderbird now this is important.

delete these files:

  • cert9.db
  • key4.db
  • logins.json

These will get created again after starting thunderbird.

Start Thunderbird.

Enter correct passwords at prompt and select checkbox to remember them. If you get a prompt from Yahoo to logon to allow Thundrebird access to server then please follow the instructions and enter password.

Modified by Toad-Hall

Helpful?

more options

Thank you, Toad-Hall. Unfortunately, that didn't help.

Helpful?

more options

I removed the Yahoo account and then added it again. Even though Thunderbird auto-configured the settings (interestingly, it was on port 587 before I removed it and now it's on 465) and Yahoo then had me go through the authorization process, I still can't send.

And I have a real disaster to deal with. Last time I set up Thunderbird to send through Yahoo, all my Yahoo folders showed up in Thunderbird. I didn't want all that mail taking up disk space on my computer, so I simply deleted them. Everything was still on Yahoo's servers. I did the same now, but this time, nothing's left on Yahoo's servers. Everything's gone. Any ideas?

Helpful?

more options

Instead of deleting the folders, which deletes them on the IMAP server, you should unsubscribe to them in TB, so they are kept on the server but not downloaded to TB.

What is the antivirus? If it's Avast or AVG, it's probably blocking the connection.

Helpful?

more options

What I meant was is there any way to retrieve them?

AVG, but I was asked if I wanted to make Yahoo's smtp server an exception, and it's there under certificates.

Helpful?

more options

I just found an option on Yahoo to request e-mail restoration. I'll let you know when they've responded.

Helpful?

more options

Look in the Trash folder for your deleted items.

Unless you want to fiddle with certificates and exceptions, I recommend removing AVG and using Windows Defender that is part of Windows. Just add the TB profile folder as an exception in WD settings.

Helpful?

more options

I'd already checked the Trash folder. But Yahoo came through for me. Everything's back! I've been using AVG for many years and won't give it up. The fiddling's already been done. I'll be most grateful if you'll stay with me and guide me to a resolution. I'm grateful now for the time and help you've given until now.

Helpful?

more options

Let's forget Yahoo for now and concentrate on my ISP's pop server. When I just started TB and clicked on Get Messages (TB has for a long time now ignored the fact that Get new messages at startup is checked), I got a messages saying that the connection had timed out. I opened this tab to post this and as I was writing, a message showed me that 45 new messages had been downloaded. Why am I getting the timed out message and how can I fix it?

Helpful?

more options

The timeouts are probably caused by AVG. Disable the Mail Shield and secure connection scanning.

Helpful?

more options

That appears (I say that because I've only had time to try Get Messages once) to have worked. Thank you!

Next: I've decided to forget about Yahoo for outgoing messages right now. You may remember that you helped me set it up because I was traveling to the U.S. and wouldn't be able to send through my ISP. I normally come to NY every Jan. or Feb., but since that's not feasible in 2021 due to COVID, we have more than a year to work on that.

My problem is that my ISP's website is woefully short on information. They do show you how to set up in Outlook, but that's it. Since I imagine you still don't read Hebrew, I won't bother giving you the link to their site. They don't provide any e-mail support, and since I have serious hearing problems, calling them isn't an option.

Any ideas?

Just tried Get Messages again. Thumbs up, sfhowes.

Helpful?

more options

I'll take a look at the ISP if you post a link. The instructions for Outlook can probably be stated in TB terms.

Helpful?

more options

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.