Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is only opening a unresponsive white window that doesn't allow me to do anything at all including close it with the "X".

  • 7 replies
  • 1 has this problem
  • 20 views
  • Last reply by catchild

more options

On a Windows 10 thinkpad running company maintained and updated MS applications and security, Firefox suddenly does not respond at all. I have done two complete shutdown/restart sequences, uninstalled and reinstalled Firefox twice, deleted all Mozilla folders and did a clean reinstall without history, deleted all temp files and Mozilla folders and did a clean reinstall....nothing. I've started it in safe mode....nothing. Help!!!!! I have to close it through the task manager/end task command.

I use Firefox on a regular basis and have never had any problems with it.

Attached screenshots

Chosen solution

thanks, so we just became aware of this problem today. it was likely introduced on your system after the recent firefox 75 update in the past couple of days. i've filed https://bugzilla.mozilla.org/show_bug.cgi?id=1629361 for mozilla's developers to look into, but until then i fear the only quick workaround would be to uninstall "netsupport school" from the system - you might want to check with your it department if this is possible.

Read this answer in context 👍 1

All Replies (7)

more options

hi, is "netsupport school" running on that device?

Helpful?

more options

I'm not sure....

Helpful?

more options

The thing that bothers me is that this happened literally one minute to the next. I was using Firefox without issues all yesterday. I closed it then reopened it and bang! nothing. I mean literally one minute it was fine, the next when I reopened it, nothing.

Helpful?

more options

catchild said

I'm not sure....

could you check if it is listed among the installed apps/programs: https://support.microsoft.com/help/4028054/

Helpful?

more options

yes it is....I checked in the programs/apps running....it's there.

Helpful?

more options

Chosen Solution

thanks, so we just became aware of this problem today. it was likely introduced on your system after the recent firefox 75 update in the past couple of days. i've filed https://bugzilla.mozilla.org/show_bug.cgi?id=1629361 for mozilla's developers to look into, but until then i fear the only quick workaround would be to uninstall "netsupport school" from the system - you might want to check with your it department if this is possible.

Modified by philipp

Helpful?

more options

Thank you so much for your prompt replies and prompt resolution to the problem. Luckily we aren't using Netsupport Education at all so it was an easy fix.

Thank you again! You saved me!!!!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.