X
Tap here to go to the mobile version of the site.

Support Forum

Dev tools missing

Posted

Hi,

Have developer edition.

When right clicking "inspect element" or arriving at that command via tools, or the hamburgers it launches right into inspect element without displaying the dev tools black screen with console, vue dev tools, etc.

This is the second time. I believe the first time I reinstalled FDE, I've just done that again.

Is there a visibility setting I'm missing?

Thank you, Trevor

Hi, Have developer edition. When right clicking "inspect element" or arriving at that command via tools, or the hamburgers it launches right into inspect element without displaying the dev tools black screen with console, vue dev tools, etc. This is the second time. I believe the first time I reinstalled FDE, I've just done that again. Is there a visibility setting I'm missing? Thank you, Trevor
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Hi Trevor, are you saying when you open the Inspector using Inspect Element or the menu that the toolbar to access the other tools is missing? Does it matter which side you dock the tools to or whether you use a floating window?

Hi Trevor, are you saying when you open the Inspector using Inspect Element or the menu that the toolbar to access the other tools is missing? Does it matter which side you dock the tools to or whether you use a floating window?
Was this helpful to you?
Quote

Question owner

Yes, exactly. Thank you for responding.

It launches right into inspect element, but no tools are available side or bottom.

Seems like a bug to me.

Yes, exactly. Thank you for responding. It launches right into inspect element, but no tools are available side or bottom. Seems like a bug to me.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Hmm, I can't replicate it on Windows in 71.0b8. You might also check on Reddit to see if it is affecting other Developer Edition users (most support volunteers use the release edition):

https://www.reddit.com/r/firefox/

Hmm, I can't replicate it on Windows in 71.0b8. You might also check on Reddit to see if it is affecting other Developer Edition users (most support volunteers use the release edition): https://www.reddit.com/r/firefox/
Was this helpful to you?
Quote

Question owner

Ok, thank you.

This is a Mac version.

Have a good weekend!

Ok, thank you. This is a Mac version. Have a good weekend!
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

Does this happen with all the 'Dock' choices (bottom, right, left, separate) ?

Can you attach a screenshot?

Does this happen with all the 'Dock' choices (bottom, right, left, separate) ? Can you attach a screenshot? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot
Was this helpful to you?
Quote

Question owner

Hi,

Here's a screen shot.

I've identified a number of ways to invoke inspect element.

  • Right click
  • Tools->web developer -> inspect element
  • Hamburgers -> web developer -> inspect element

All of them, invariably, go direct to to inspect like this. There's no way to get my tool box.

Very frustrating.

Any ideas?

Thank you, Trevor

Hi, Here's a screen shot. I've identified a number of ways to invoke inspect element. * Right click * Tools->web developer -> inspect element * Hamburgers -> web developer -> inspect element All of them, invariably, go direct to to inspect like this. There's no way to get my tool box. Very frustrating. Any ideas? Thank you, Trevor
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

So, the actual developer toolbox is missing and you only see its effect on the the web page.

Are you possibly in full screen mode (Mac: Command+Shift+F)?

Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

So, the actual developer toolbox is missing and you only see its effect on the the web page. Are you possibly in full screen mode (Mac: Command+Shift+F)? Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles
Was this helpful to you?
Quote

Question owner

Hi,

After deleting xulstore.json the problem persists.

I don't generally use full screen, so I can see other things, but I tried using it and the problem persists.

Any other ideas?

Thank you,

Trevor

Hi, After deleting xulstore.json the problem persists. I don't generally use full screen, so I can see other things, but I tried using it and the problem persists. Any other ideas? Thank you, Trevor
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.