X
Tap here to go to the mobile version of the site.

Support Forum

Icon fonts not displaying on websites using Mac OS Catalina but same websites fine on Windows running Firefox 7.00

Posted

Allow pages to choose their own fonts, instead of your selections above in preferences sorts out my font problems but then Icon Fonts don't work. Please see screenshot. I have a windows laptop running Firefox 7.0 as well and this is fine so it's a Mac OS Catalina 10.15 and FontExplorer Pro. Help!!!

Allow pages to choose their own fonts, instead of your selections above in preferences sorts out my font problems but then Icon Fonts don't work. Please see screenshot. I have a windows laptop running Firefox 7.0 as well and this is fine so it's a Mac OS Catalina 10.15 and FontExplorer Pro. Help!!!
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17589 solutions 159105 answers

You wrote: Allow pages to choose their own fonts, instead of your selections above in preferences sorts out my font problems but then Icon Fonts don't work., instead of your selections above in preferences sorts out my font problems but then Icon Fonts don't work.

I assume that you mean the opposite and that unchecking this setting worked for fixing the font issue. If you disable "Allow pages to choose their own fonts" then you do not see icon fonts like you noticed.

Did you check what font is causing your issue with the last resort ('?') font ?

We have seen some reports that an Helvetica or Arial font is causing this issue.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

You wrote: ''Allow pages to choose their own fonts, instead of your selections above in preferences sorts out my font problems but then Icon Fonts don't work., instead of your selections above in preferences sorts out my font problems but then Icon Fonts don't work.'' I assume that you mean the opposite and that unchecking this setting worked for fixing the font issue. If you disable "Allow pages to choose their own fonts" then you do not see icon fonts like you noticed. Did you check what font is causing your issue with the last resort ('?') font ? We have seen some reports that an Helvetica or Arial font is causing this issue. You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts
Was this helpful to you?
Quote

Question owner

Sorry this has totally confused me!

I have unclicked “Allow pages to choose their own fonts, instead of your selections above”

So I'm not allowing pages to choose their own fonts.

Looking at the developer tools it looks like a clash with

webkit-font-smoothing: antiliased;


It is elements like arrows and telephone images that are not displaying properly.

Sorry this has totally confused me! I have unclicked “Allow pages to choose their own fonts, instead of your selections above” So I'm not allowing pages to choose their own fonts. Looking at the developer tools it looks like a clash with webkit-font-smoothing: antiliased; It is elements like arrows and telephone images that are not displaying properly.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17589 solutions 159105 answers

When you disable "Allow pages to choose their own fonts, instead of my selections above" then you won't be able to see icon fonts like I wrote above. There is no way to use icon fonts downloaded via @font-face rules from internet with this option disabled.

You will have to place a checkmark on this setting and fix the '?' font issue otherwise.

When you disable "Allow pages to choose their own fonts, instead of my selections above" then you won't be able to see icon fonts like I wrote above. There is no way to use icon fonts downloaded via @font-face rules from internet with this option disabled. You will have to place a checkmark on this setting and fix the '?' font issue otherwise.
Was this helpful to you?
Quote

Question owner

Either way I can’t live with ????? When I use Firefox, I’m afraid I have resorted to having to use Safari. It is fine on Windows so must be a Mac OS problem. Your first reply it doesn’t correspond to what I see on my screen, sorry I’ve lost patience now. Thanks for your help.

Either way I can’t live with ????? When I use Firefox, I’m afraid I have resorted to having to use Safari. It is fine on Windows so must be a Mac OS problem. Your first reply it doesn’t correspond to what I see on my screen, sorry I’ve lost patience now. Thanks for your help.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17589 solutions 159105 answers

You get the '?' because Firefox for some reasons isn't able to access the font that is specified by the website and uses a last resort font instead.

The Font inspector should tell you what font this is about.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.


mThis likely means that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

You get the '?' because Firefox for some reasons isn't able to access the font that is specified by the website and uses a last resort font instead. The Font inspector should tell you what font this is about. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML ---- mThis likely means that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'. You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. *https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.