X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 69 broke all cookie exceptions

Posted

Goal: BLOCK ALL cookies using the strictest setting, then use the (archaic) exception interface to allow specific cookies to be set so that specific websites function enough to be utilized as intended.

Firstly, I am a very experienced Firefox user of many years. I have had my firefox set up as described above since installation, so it's not some operator error problem.

I'm uploading three screenshots that will spell out my problem in black and white.

The specific issue --as shown in the images-- is that immediately after installing firefox 69 all my exceptions no longer function at all.

As you can see in the image showing site information "mail.google" and "accounts.google" are being allowed. This is because I used the right-click method on the site to create a cookie exception via site permissions under the "View Page Info", so please ignore those two for the purpose of this discussion. If you'll notice in the same image, "https://www.google.com" shows as Blocked with a tiny X next to it. As shown in the image of the (archaic) Cookie Exceptions Interface, the very same site "https://www.google.com" is clearly set to "Allow". If I click the tiny X next to "https://www.google.com" in the Site Information's Cookie section (as shown in Image one) the "exception" is removed and it just shows "Blocked" as it does in the "play.google.com" entry.Re-adding the exception to the Exceptions lists restores that tiny X but the cookie remains blocked. I have already covered adding redundancies and variants of each domain such as both HTTP and HTTPS etc. I have noticed, however, that entries like "google.com" which used to cover all possible variations by avoiding the prefix altogether have entirely disappeared. It is my theory that this is part of the problem, but on this I am no expert.

In summary, I would like to restore my FF69 to what it was before FF69: with all cookies blocked and a few select cookies allowed through. Drastic actions like refreshing everything to new and that sort of thing I do not believe is the solution. What I am hoping for here is to alert developers so that they can fix it in an upcoming patch.

Irrelevant Comments: I had a terrible time trying to utilize this forum. I try to never make accounts and was forced to do so to post here. Fair enough, but in order to do so I had to use Microsoft Edge (BLECH!) because the site simply would not function on Firefox. This is likely to very strict settings on my end but I must say that many other forums work flawlessly. I find this disappointing.


I believe it is time for an entirely new cookie exception interface where entries can be sorted, modified and easily accessed. If you've ever scrolled through 8 zillion exceptions you know what I mean. The Site Preferences interface's cookie & site data entries should be click-able with easy ways to allow or disallow. An advanced mode (with a warning for beginners) allowing more comprehensive exceptions on per cookie basis with features like are available in the browser extension named CookieBro would be absolutely ideal. Firefox seems to be becoming less and less friendly to the advanced user with less and less control over content on a per-site basis. My apologies for including some feedback here, but I can't find anywhere else to send it.

Thank you one and all for your time in advance, and any solutions that don't involve catastrophic actions will be greatly appreciated.

Goal: BLOCK ALL cookies using the strictest setting, then use the (archaic) exception interface to allow specific cookies to be set so that specific websites function enough to be utilized as intended. Firstly, I am a very experienced Firefox user of many years. I have had my firefox set up as described above since installation, so it's not some operator error problem. I'm uploading three screenshots that will spell out my problem in black and white. The specific issue --as shown in the images-- is that immediately after installing firefox 69 all my exceptions no longer function at all. As you can see in the image showing site information "mail.google" and "accounts.google" are being allowed. This is because I used the right-click method on the site to create a cookie exception via site permissions under the "View Page Info", so please ignore those two for the purpose of this discussion. If you'll notice in the same image, "https://www.google.com" shows as Blocked with a tiny X next to it. As shown in the image of the (archaic) Cookie Exceptions Interface, the very same site "https://www.google.com" is clearly set to "Allow". If I click the tiny X next to "https://www.google.com" in the Site Information's Cookie section (as shown in Image one) the "exception" is removed and it just shows "Blocked" as it does in the "play.google.com" entry.Re-adding the exception to the Exceptions lists restores that tiny X but the cookie remains blocked. I have already covered adding redundancies and variants of each domain such as both HTTP and HTTPS etc. I have noticed, however, that entries like "google.com" which used to cover all possible variations by avoiding the prefix altogether have entirely disappeared. It is my theory that this is part of the problem, but on this I am no expert. In summary, I would like to restore my FF69 to what it was before FF69: with all cookies blocked and a few select cookies allowed through. Drastic actions like refreshing everything to new and that sort of thing I do not believe is the solution. What I am hoping for here is to alert developers so that they can fix it in an upcoming patch. Irrelevant Comments: I had a terrible time trying to utilize this forum. I try to never make accounts and was forced to do so to post here. Fair enough, but in order to do so I had to use Microsoft Edge (BLECH!) because the site simply would not function on Firefox. This is likely to very strict settings on my end but I must say that many other forums work flawlessly. I find this disappointing. I believe it is time for an entirely new cookie exception interface where entries can be sorted, modified and easily accessed. If you've ever scrolled through 8 zillion exceptions you know what I mean. The Site Preferences interface's cookie & site data entries should be click-able with easy ways to allow or disallow. An advanced mode (with a warning for beginners) allowing more comprehensive exceptions on per cookie basis with features like are available in the browser extension named CookieBro would be absolutely ideal. Firefox seems to be becoming less and less friendly to the advanced user with less and less control over content on a per-site basis. My apologies for including some feedback here, but I can't find anywhere else to send it. Thank you one and all for your time in advance, and any solutions that don't involve catastrophic actions will be greatly appreciated.
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

N/A

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/17.17134

More Information

Question owner

I should add that I never save any cookies and clear everything each time I exit the browser EXCEPT site preferences. Thanks again.

I should add that I never save any cookies and clear everything each time I exit the browser EXCEPT site preferences. Thanks again.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17525 solutions 158458 answers

If you want to create an allow exception for a top level domain then use https://google.com instead of specifying each domain separately. If you have a very large exception list then the response will be slower as Firefox needs to check the entire list with each request to decide whether to send cookies. Maybe consider to use a cookie management extension that allow more control.

If you want to create an allow exception for a top level domain then use https://google.com instead of specifying each domain separately. If you have a very large exception list then the response will be slower as Firefox needs to check the entire list with each request to decide whether to send cookies. Maybe consider to use a cookie management extension that allow more control.
Was this helpful to you?
Quote

Question owner

cor-el said

If you want to create an allow exception for a top level domain then use https://google.com instead of specifying each domain separately. If you have a very large exception list then the response will be slower as Firefox needs to check the entire list with each request to decide whether to send cookies. Maybe consider to use a cookie management extension that allow more control.

Hi Cor-el, thank you for your time. Unfortunately, your response has zero to do with my problem. Thank you for your cookie management extension suggestion, but this is not the issue at all. I simply want FF to behave as it always has.

Anyone else? Mozilla?

I should also add that this exact issue is occurring on 2 separate machines. One of which I make extensive customizations on, and the other a default, clean installation with no modifications other than a few extensions (which are not the problem).

Thanks again in advance for every one's time.

''cor-el [[#answer-1255997|said]]'' <blockquote> If you want to create an allow exception for a top level domain then use https://google.com instead of specifying each domain separately. If you have a very large exception list then the response will be slower as Firefox needs to check the entire list with each request to decide whether to send cookies. Maybe consider to use a cookie management extension that allow more control. </blockquote> Hi Cor-el, thank you for your time. Unfortunately, your response has zero to do with my problem. Thank you for your cookie management extension suggestion, but this is not the issue at all. I simply want FF to behave as it always has. Anyone else? Mozilla? I should also add that this exact issue is occurring on 2 separate machines. One of which I make extensive customizations on, and the other a default, clean installation with no modifications other than a few extensions (which are not the problem). Thanks again in advance for every one's time.
Was this helpful to you?
Quote

Question owner

New information:

Updated to version 69.0.2 (64-bit) today. Two machines, no change.


9 views...…  :-(


1 Unhelpful reply....  :-(


Would appreciate any other ideas.

Thank you.

New information: Updated to version 69.0.2 (64-bit) today. Two machines, no change. 9 views...… :-( 1 Unhelpful reply.... :-( Would appreciate any other ideas. Thank you.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

What URL is that you're testing with?

Settings scenario for comparison:

  • Regular (non-private) window
  • Cookie behavior not modified by extensions
  • Not using containers to isolate the site or third party domains used in the site
  • First-party isolation has default value of false (privacy.firstparty.isolate in about:config)

If you open the Storage Inspector on the page (Shift+F9), does Firefox show that it has stored cookies for https://www.google.com or not? How about https://google.com ?

I suppose it's possible cookies have been stored but are not being sent back to the site. It's difficult to see that using the built-in tools without a deep dive into the Network Monitor.

Ref.

What URL is that you're testing with? Settings scenario for comparison: * Regular (non-private) window * Cookie behavior not modified by extensions * Not using containers to isolate the site or third party domains used in the site * First-party isolation has default value of false (privacy.firstparty.isolate in about:config) If you open the Storage Inspector on the page (Shift+F9), does Firefox show that it has stored cookies for https://www.google.com or not? How about https://google.com ? I suppose it's possible cookies have been stored but are not being sent back to the site. It's difficult to see that using the built-in tools without a deep dive into the Network Monitor. Ref. * https://developer.mozilla.org/docs/Tools/Storage_Inspector * https://developer.mozilla.org/docs/Tools/Network_Monitor
Was this helpful to you?
Quote

Question owner

jscher2000 said

What URL is that you're testing with? Settings scenario for comparison:
  • Regular (non-private) window
  • Cookie behavior not modified by extensions
  • Not using containers to isolate the site or third party domains used in the site
  • First-party isolation has default value of false (privacy.firstparty.isolate in about:config)

FPI seems to be the culprit, however, this setting has been set to TRUE since it was implemented in Firefox 55. Changing it to FALSE has solved the issue and now cookies in the exception list are being accepted properly with all remaining cookies being blocked globally.

This solves the problem in one sense but I prefer FPI to be set to TRUE as it has always been. Is this a bug that needs to be corrected in a future patch? How can I keep my FPI set to true and have my system behave as it did prior to FF69?

Answers to other requested information: Regular (non-private) window - CORRECT (Normal window)

Cookie behavior not modified by extensions - INCORRECT (I use Cookiebro to do all the things Firefox is horribly lacking in, such as denying specific cookies that are not required for full functionality. I have, however, eliminated this excellent extension as a possible cause.

Not using containers to isolate the site or third party domains used in the site - CORRECT (Containers not being used)

In all cases cookies are being stored once I allow them via "View Page Information: Permissions" (which has been my work-around) but NOT stored when they are shown as "Blocked" in the Site Information > Cookies and Site Data" interface accessible via the address bar.

For now I will continue to keep First-Party Isolation enabled while allowing what I need for functionality through "View Page Information: Permissions" until a patch correcting this or a solution is posted here.

Thank you, Jsher2000, you nailed the issue. Any further thoughts you might have will be appreciated. I've included two screenshots showing the issue being corrected by setting First-Party Isolation to FALSE. This is the only change I made.

At the very least, I hope this post provides an answer for someone else who is plagued with this issue. At most, my hope is to keep FPI (TRUE) as it always has been since its inception and still have Firefox behave as it did before v69.

Thanks again for every one's time.

''jscher2000 [[#answer-1256740|said]]'' <blockquote> What URL is that you're testing with? Settings scenario for comparison: * Regular (non-private) window * Cookie behavior not modified by extensions * Not using containers to isolate the site or third party domains used in the site * First-party isolation has default value of false (privacy.firstparty.isolate in about:config) </blockquote> FPI seems to be the culprit, however, this setting has been set to TRUE since it was implemented in Firefox 55. Changing it to FALSE has solved the issue and now cookies in the exception list are being accepted properly with all remaining cookies being blocked globally. '''This solves the problem in one sense but I prefer FPI to be set to TRUE as it has always been. Is this a bug that needs to be corrected in a future patch? How can I keep my FPI set to true and have my system behave as it did prior to FF69?''' Answers to other requested information: Regular (non-private) window - CORRECT (Normal window) Cookie behavior not modified by extensions - INCORRECT (I use Cookiebro to do all the things Firefox is horribly lacking in, such as denying specific cookies that are not required for full functionality. I have, however, eliminated this excellent extension as a possible cause. Not using containers to isolate the site or third party domains used in the site - CORRECT (Containers not being used) In all cases cookies are being stored once I allow them via "View Page Information: Permissions" (which has been my work-around) but NOT stored when they are shown as "Blocked" in the Site Information > Cookies and Site Data" interface accessible via the address bar. For now I will continue to keep First-Party Isolation enabled while allowing what I need for functionality through "View Page Information: Permissions" until a patch correcting this or a solution is posted here. Thank you, Jsher2000, you nailed the issue. Any further thoughts you might have will be appreciated. I've included two screenshots showing the issue being corrected by setting First-Party Isolation to FALSE. This is the only change I made. At the very least, I hope this post provides an answer for someone else who is plagued with this issue. At most, my hope is to keep FPI (TRUE) as it always has been since its inception and still have Firefox behave as it did before v69. Thanks again for every one's time.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17525 solutions 158458 answers

Helpful Reply

See also:

  • bug 1556212 - Per-Domain Cookie Permissions are broken with FPI enabled

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

See also: *bug 1556212 - Per-Domain Cookie Permissions are broken with FPI enabled (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.