X
Tap here to go to the mobile version of the site.

Support Forum

Firefox consistently hangs after installing the Windows 10 1903 update

tty
Posted

Firefox version: 68.0 x64

Firefox version: 68.0 x64
Quote

Additional System Details

Installed Plug-ins

n/a

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18362

More Information

My_Cheese_Is_Slippin'
  • Top 10 Contributor
39 solutions 459 answers

Hi tty, Yes, I hear there are a lot of headaches out there. I'm glad that I didn't get it. Anyway, is when you are using Firefox the only time that you notice "hanging"? There are quite a few troubleshooting methods. For example, Firefox has a Safe Mode and a Refresh option. None of these methods will lose any of your bookmarks, browsing history, open tabs, windows, passwords, cookies or web form auto-fill information. You may lose add-ons, though. See this article: Troubleshoot and diagnose Firefox problems See if anything there helps. Post back if you have any questions.

Hi tty, Yes, I hear there are a lot of headaches out there. I'm glad that I didn't get it. Anyway, is when you are using Firefox the only time that you notice "hanging"? There are quite a few troubleshooting methods. For example, Firefox has a Safe Mode and a Refresh option. None of these methods will lose any of your bookmarks, browsing history, open tabs, windows, passwords, cookies or web form auto-fill information. You may lose add-ons, though. See this article: [https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems Troubleshoot and diagnose Firefox problems] See if anything there helps. Post back if you have any questions.
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
39 solutions 459 answers

Hi again tty, Something that I thought of that you might be interested in trying is: Malwarebytes AdwCleaner This is recommended for Adware & Malware removal but, take a look at the settings. There is an array of networking resets which might resolve your issue.

Hi again tty, Something that I thought of that you might be interested in trying is: [https://support.malwarebytes.com/docs/DOC-1160 Malwarebytes AdwCleaner] This is recommended for Adware & Malware removal but, take a look at the settings. There is an array of networking resets which might resolve your issue.
Was this helpful to you?
Quote

Question owner

x86 works, with no issues.

x86 works, with no issues.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.