Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

A virtual/floating keyboard keeps appearing. How do I get rid of it?

  • 2 replies
  • 1 has this problem
  • 54 views
  • Last reply by appraisenj

more options

This virtual/floating keyboard only appears when I use Firefox. Why and how do I get rid of it?

Chosen solution

Hi appraisenj, do you have a "convertible" device, i.e., sometimes it is a tablet and sometimes it is a laptop??

There are some settings you could switch to see whether you can get rid of the on-screen keyboard:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste osk and pause while the list is filtered

Try:

(3) Double-click the ui.osk.detect_physical_keyboard preference to switch the value from true to false

(4) Double-click the ui.osk.enabled preference to switch the value from true to false

Any improvement?

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Hi appraisenj, do you have a "convertible" device, i.e., sometimes it is a tablet and sometimes it is a laptop??

There are some settings you could switch to see whether you can get rid of the on-screen keyboard:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste osk and pause while the list is filtered

Try:

(3) Double-click the ui.osk.detect_physical_keyboard preference to switch the value from true to false

(4) Double-click the ui.osk.enabled preference to switch the value from true to false

Any improvement?

more options

That put me in the right direction. Thank you